Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21250

NullPointerException in AggregatedTestResultPublisher causes Job to fail after upgrade from 1.544 to 1.545+

    XMLWordPrintable

Details

    Description

      We have a job which triggers three other jobs and aggregates their test results using post build actions:

      • Aggregate post build test results (german: "Nachgelagerte Testergebnisse zusammenfassen")
        • [x] Aggregate all post build jobs
        • [x] Aggregate failed build result
      • Build jobs (german: "Weitere Projekte bauen")
        • [x] trigger only on build success
        • [ ] trigger even when build is instable
        • [ ] trigger even when build fails

      When starting this job it fails quickly with an NullPointer exception:

      Started by user anonymous
      Building in workspace /ps/devop/jenkins/data/jobs/selenium_firefox/workspace
      ERROR: Publisher hudson.tasks.test.AggregatedTestResultPublisher aborted due to exception
      java.lang.NullPointerException
      	at hudson.tasks.test.AggregatedTestResultPublisher$TestResultAction.getProject(AggregatedTestResultPublisher.java:173)
      	at hudson.tasks.test.AggregatedTestResultPublisher$TestResultAction.<init>(AggregatedTestResultPublisher.java:146)
      	at hudson.tasks.test.AggregatedTestResultPublisher$TestResultAction.<init>(AggregatedTestResultPublisher.java:135)
      	at hudson.tasks.test.AggregatedTestResultPublisher.perform(AggregatedTestResultPublisher.java:90)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:757)
      	at hudson.model.Build$BuildExecution.post2(Build.java:183)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:706)
      	at hudson.model.Run.execute(Run.java:1703)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:231)
      Finished: FAILURE
      

      The aggregation is crucial for our dashboard which displays the overall testresults history chart.

      P.S.: Sorry, I only use the german translation, so I just guessed the actual english configuration lables above.

      Attachments

        Issue Links

          Activity

            npfistner Norbert Pfistner created issue -

            The effected versions are 1.545 and 1.546 so far.
            Switching back to version 1.544 fixes the bug but is for sure no suitable solution.

            npfistner Norbert Pfistner added a comment - The effected versions are 1.545 and 1.546 so far. Switching back to version 1.544 fixes the bug but is for sure no suitable solution.
            vjuranek vjuranek made changes -
            Field Original Value New Value
            Assignee vjuranek [ vjuranek ] Lucie Votypkova [ lvotypkova ]

            The problem is how to rollback a new installation of jenkins as a service on CentOs. =/

            r_martins Ricardo Martins added a comment - The problem is how to rollback a new installation of jenkins as a service on CentOs. =/

            I just replaced my .war for an old version and it works. Thanks npfistner.

            r_martins Ricardo Martins added a comment - I just replaced my .war for an old version and it works. Thanks npfistner .
            hackmann Hack Kampbjørn made changes -
            Link This issue is duplicated by JENKINS-21255 [ JENKINS-21255 ]
            bedge Bruce Edge added a comment -

            Confirming that 1.544 is the last version where this is not a problem.

            bedge Bruce Edge added a comment - Confirming that 1.544 is the last version where this is not a problem.

            I will look at it, it seems that something was changed.

            lvotypkova Lucie Votypkova added a comment - I will look at it, it seems that something was changed.

            Bruce Edge, I've read (somewhere) that this should be fixed in 1.547, released yesterday. Could you test it please?

            henriquer Henrique Rodrigues added a comment - Bruce Edge, I've read (somewhere) that this should be fixed in 1.547, released yesterday. Could you test it please?

            I can confirm that this is fixed in 1.547

            hackmann Hack Kampbjørn added a comment - I can confirm that this is fixed in 1.547

            I can also confirm that this is fixed in 1.547

            Many thanks!

            npfistner Norbert Pfistner added a comment - I can also confirm that this is fixed in 1.547 Many thanks!
            miquelmartin Miquel Martin added a comment -

            One more confirmation that it now works from my side, thanks a bunch!

            miquelmartin Miquel Martin added a comment - One more confirmation that it now works from my side, thanks a bunch!

            WFM with 1.547 again.

            opi Alexander Opitz added a comment - WFM with 1.547 again.
            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-18410 [ JENKINS-18410 ]
            jglick Jesse Glick made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 153113 ] JNJira + In-Review [ 194470 ]

            People

              lvotypkova Lucie Votypkova
              npfistner Norbert Pfistner
              Votes:
              16 Vote for this issue
              Watchers:
              23 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: