Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21255

NullPointerException on hudson.tasks.test.AggregatedTestResultPublisher$TestResultAction.getProject(..)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Ubuntu 64bit
    • Similar Issues:

      Description

      When enabling "Aggregate downstream test results" post-build action, I'm getting this error in v1.545 and v1.546.

      [ANALYSIS-COLLECTOR] Computing warning deltas based on reference build #34
      ERROR: Publisher hudson.tasks.test.AggregatedTestResultPublisher aborted due to exception
      java.lang.NullPointerException
      at hudson.tasks.test.AggregatedTestResultPublisher$TestResultAction.getProject(AggregatedTestResultPublisher.java:173)
      at hudson.tasks.test.AggregatedTestResultPublisher$TestResultAction.<init>(AggregatedTestResultPublisher.java:146)
      at hudson.tasks.test.AggregatedTestResultPublisher$TestResultAction.<init>(AggregatedTestResultPublisher.java:135)
      at hudson.tasks.test.AggregatedTestResultPublisher.perform(AggregatedTestResultPublisher.java:90)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:757)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1030)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:706)
      at hudson.model.Run.execute(Run.java:1703)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:519)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:231)

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Wrong component, unrelated to analysis collector.

            hackmann Hack Kampbjørn added a comment -

            This seems to be a duplicate of JENKINS-21250

            jglick Jesse Glick added a comment -

            Fix in 1.547.

            habj herlani junior added a comment -

            Still in 1.563. See stack attached !

            drulli Ulli Hafner added a comment -

            @herlani junior: your exception is unrelated.

            mattsheppard Matthew Sheppard added a comment -

            @herlani junior - seems like the issue you were reporting is tracked as JENKINS-23123. I imagine you long since ceased to care, but I'm recording it here since this (or actually, your attached stack trace) is where Google brought me first when I hit the same problem.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              meteoric Choon Chern Lim
              Votes:
              6 Vote for this issue
              Watchers:
              13 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: