Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21749

builds seem to hang forever and can't be canceled, but actually complete

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: core
    • Labels:
    • Environment:
      Mac OS X Server (10.9.1)
      Tomcat 7.0.47
      Jenkins 1.546
    • Similar Issues:

      Description

      Certain of our jobs will intermittently hang forever. When this happens they cannot be canceled via the Jenkins webapp. Clicking on the red [x] has no effect and Jenkins must be restarted in order for the offending jobs to be cleared from the queue.

      Interestingly, once Jenkins restarts these jobs show as up as having completed successfully. So the jobs are finishing but Jenkins isn't "noticing". The "cancel" functionality is probably failing because the job has, in fact, already completed and there's nothing to cancel.

      The affected jobs use a combination of bash and ruby scripts that are executed from within the "Execute shell" section in the job configuration.

      I will update this ticket with a thread dump the next time I notice a hang happening.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Any news?

          danielbeck Daniel Beck added a comment -

          Resolving as Incomplete after no response for 2+ weeks to comment asking for updated and additional information, and the original issue report started out incomplete as well.

          buddyglass Jay Howard added a comment -

          I apologize, Daniel. I just realized the Jenkins-related JIRA emails were going into a spam folder. Hence my radio silence. As far as I can tell, the issues that prompted this ticket were caused by some underlying network issues that were the result of a poorly configured firewall sitting between our build machine various other machines accessed during our builds. TCP connections were getting borked at the packet level, and apparently the networking code (somewhere, possibly not in Jenkins) doesn't handle the case when a low level socket operation blocks indefinitely.

          danielbeck Daniel Beck added a comment -

          Hi Jay,

          not a problem. This is just housekeeping and can be reopened at any time if it turns out it's a real Jenkins issue – which in this case it doesn't seem to be, so let's leave it as it is.

          Thanks for following up!


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            buddyglass Jay Howard
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: