Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22006

IBM JDK agent disconnects in 1.532.2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      RHEL 6. Jenkins running behind Tomcat
    • Similar Issues:

      Description

      Hi,

      I tried to upgrade jenkins from previous stable release 1.532.1 to 1.532.2. While the upgrade worked properly(LDAP, jobs, etc worked), slave agents on RHEL 6 servers are not persistent. They vanish after Tomcat reboot. Below is my setup.

      OS: RHEL 6
      Tomcat: 7.0.42
      Jenkins: 1.532.2
      Java: IBM Java 1.6.0

      Could someone please look into it.

      Please let me know if any more info is required.

      Thanks,
      Abhishek

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            What exactly do you mean by "not persistent", "vanish"? They don't connect? They simply disappear from Jenkins configuration?

            Anything interesting in the Jenkins log?

            amalhotra Abhishek Malhotra added a comment -

            They do connect, but disappear from Jenkins configuration the moment Tomcat is restarted. I also checked for the slave process(thought it was a problem with UI), but the slave process was also not running. Couldn't find anything in Jenkin logs.

            When I am creating a new slave, Jenkins UI shows Time out on the slave, but Slave logs show that it started successfully. On subsequent refresh of nodes, finally it shows that Slave is up and running. I then check the slave process on the server and it is running. Then I restart the Tomcat and slave node disappears from the configuration.

            This is happening with the new Stable release(1.532.2). Previous release works fine on same configuration.

            oleg_nenashev Oleg Nenashev added a comment -

            Linked the issue to JENKINS-23176
            The issue could be a duplicate of JENKINS-22525

            martinkutter Martin Kutter added a comment -

            I'm running Jenkins-1.532.2 LTS on Tomcat 7 with IBM JDK 7 on AIX, and I'm unable to reproduce this.

            Are the slaves written to config.xml in JENKINS_HOME?
            Are there errors in Catalina.out on startup? I had something similar with all views disappearing - turned out that my config.xml had a corrupted entry (bad reference), and Jenkins didn't load anything past this entry.

            Does the error also occur with a fresh Jenkins (no previous configuration)?

            markewaite Mark Waite added a comment - - edited

            I've been running 2.204.x on a Linux master in Docker and am now running Jenkins 2.222.1 on the same Linux master. An IBM s390x agent is connected to that Linux master. The Linux Docker master is running OpenJDK 8u242 Hotspot while the IBM s390x agent is running JDK 8u242 OpenJ9. I use that agent to build and run various tests, including:

            • Compile and test the Jenkins git plugin 4.x
            • Compile and test the Jenkins git client plugin 3x
            • Compile and test the Jenkins platform labeler plugin

            Unless there is new information on this bug report, I propose to close it.

            I'm also running an OpenJDK 8u242 agent on PowerPC 64 running Ubuntu. Also working very well.


              People

              Assignee:
              markewaite Mark Waite
              Reporter:
              amalhotra Abhishek Malhotra
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: