Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22175

slave nodes are forgotten

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      We experienced that one of nine jenkins slave/worker nodes is forgotten on every jenkins restart.
      Manually re-adding nodes again and again is very cumbersome - especially since there is no API for that.
      We would appreciate help for deeper debugging this issue.

        Attachments

          Issue Links

            Activity

            Hide
            bmwiedemann Bernhard Wiedemann added a comment -

            Further analysis showed that config.xml still contained the missing slave entry, but jenkins consistently ignored the first <slave>...</slave> part for its live data.

            Show
            bmwiedemann Bernhard Wiedemann added a comment - Further analysis showed that config.xml still contained the missing slave entry, but jenkins consistently ignored the first <slave>...</slave> part for its live data.
            Hide
            danielbeck Daniel Beck added a comment -

            JENKINS-22525 has more watchers, so I'm closing this one as duplicate despite being reported earlier.

            Show
            danielbeck Daniel Beck added a comment - JENKINS-22525 has more watchers, so I'm closing this one as duplicate despite being reported earlier.

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              bmwiedemann Bernhard Wiedemann
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: