Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22251

Executing tf using the TFS Plugin throws an IO exception

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • tfs-plugin
    • None
    • Jenkins master is Linux. Slave node is Windows 7 machine.

    Description

      When executing the TFS Plugin from a Linux master to a Windows 7 slave I am getting the following error:

      17:00:52 [EnvInject] - Loading node environment variables.
      17:00:53 Building remotely on VMWAYQA09 in workspace C:\jenkins-slave\workspace\AUT-Geb-Demo
      17:00:53 [AUT-Geb-Demo] $ tf workspaces -format:brief -server:http://<server>:8080/tfs/2x ********
      17:00:53 java.io.IOException: Cannot run program "tf" (in directory "C:\jenkins-slave\workspace\AUT-Geb-Demo"): CreateProcess error=2, The system cannot find the file specified
      17:00:53 at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
      17:00:53 at hudson.Proc$LocalProc.<init>(Proc.java:244)
      17:00:53 at hudson.Proc$LocalProc.<init>(Proc.java:216)
      17:00:53 at hudson.Launcher$LocalLauncher.launch(Launcher.java:773)
      17:00:53 at hudson.Launcher$ProcStarter.start(Launcher.java:353)
      17:00:53 at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:998)
      17:00:53 at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:965)
      17:00:53 at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      17:00:53 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      17:00:53 at hudson.remoting.Request$2.run(Request.java:328)
      17:00:53 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      17:00:53 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      17:00:53 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      17:00:53 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
      17:00:53 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
      17:00:53 at hudson.remoting.Engine$1$1.run(Engine.java:63)
      17:00:53 at java.lang.Thread.run(Thread.java:662)
      17:00:53 Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
      17:00:53 at java.lang.ProcessImpl.create(Native Method)
      17:00:53 at java.lang.ProcessImpl.<init>(ProcessImpl.java:81)
      17:00:53 at java.lang.ProcessImpl.start(ProcessImpl.java:30)
      17:00:53 at java.lang.ProcessBuilder.start(ProcessBuilder.java:453)
      17:00:53 ... 16 more
      17:00:53 Finished: FAILURE

      Attachments

        Issue Links

          Activity

            Also - needs to be mentioned that we have tried the following and they are successful. Hence, the hunch is that an issue with the plugin.

            1. Executing the tf command by configuring a job as a Windows batch command on the slave works successfully.
            2. Exceuting the tf command using the script console like this works successfully:

            Process p = "cmd /c tf".execute()
            println "${p.text}"

            renuc Renu Chudamani added a comment - Also - needs to be mentioned that we have tried the following and they are successful. Hence, the hunch is that an issue with the plugin. 1. Executing the tf command by configuring a job as a Windows batch command on the slave works successfully. 2. Exceuting the tf command using the script console like this works successfully: Process p = "cmd /c tf".execute() println "${p.text}"
            zivtir Ziv Tirosh added a comment -

            hi change the Path system variable to your IDE : C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE

            zivtir Ziv Tirosh added a comment - hi change the Path system variable to your IDE : C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE
            simpligility Manfred Moser added a comment -

            This can probably be closed since the 4.0.0 version of the plugin uses the Java SDK only.

            simpligility Manfred Moser added a comment - This can probably be closed since the 4.0.0 version of the plugin uses the Java SDK only.

            Version 4.0.0 of the plugin no longer uses the CLC and should no longer have this issue.

            oli_at_jsi Olivier Dagenais added a comment - Version 4.0.0 of the plugin no longer uses the CLC and should no longer have this issue.

            People

              renuc Renu Chudamani
              renuc Renu Chudamani
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: