Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22579

Failing to process NUnit results xml

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: nunit-plugin
    • Labels:
      None
    • Environment:
      Jenkins: 1.556
      NUnit plugin: 0.15
    • Similar Issues:

      Description

      I am getting the following error when I try to use the plugin. I did a quick glance at the xml and it looked good. Any help is much appreciated.

      Recording NUnit tests results
      ERROR: Publisher hudson.plugins.nunit.NUnitPublisher aborted due to exception
      hudson.util.IOException2: Could not transform the NUnit report. Please report this issue to the plugin author
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:57)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:26)
      at hudson.FilePath.act(FilePath.java:914)
      at hudson.FilePath.act(FilePath.java:887)
      at hudson.plugins.nunit.NUnitPublisher.perform(NUnitPublisher.java:116)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:742)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:714)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:663)
      at hudson.model.Run.execute(Run.java:1713)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:231)
      Caused by: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The markup in the document following the root element must be well-formed.
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:758)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:359)
      at hudson.plugins.nunit.NUnitReportTransformer.transform(NUnitReportTransformer.java:67)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:55)
      ... 13 more
      Caused by: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The markup in the document following the root element must be well-formed.
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:587)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:748)
      ... 16 more
      Caused by: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The markup in the document following the root element must be well-formed.
      at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:464)
      at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:252)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:565)
      ... 17 more
      Finished: FAILURE

        Attachments

          Activity

          dginga Dick Ginga added a comment -

          I am also hitting this problem after I changed the test report xmls to TestResults/*.xml. it was working fine for a single xml.

          dginga Dick Ginga added a comment -

          found my problem. another user lack of knowledge. wrong formatted file

          tenwit Paul Hicks added a comment -

          OP says that the problem was not with the plugin


            People

            Assignee:
            redsolo redsolo
            Reporter:
            nick_wilmes Nick Wilmes
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: