Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2284

Details of Warnings no longer display after update

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • warnings-plugin
    • None
    • Platform: All, OS: All

    Description

      After updating to the Warnings plugin 1.11, the details of warnings are no
      longer being shown in the browser. The compiler-warnings.xml file still seems
      to exist and is correct.

      Hudson version is 1.251 – same result in IE and Firefox 3.0

      Will attach screen shot

      Attachments

        Activity

          smithgcovert smithgcovert added a comment -

          Created an attachment (id=360)
          screenshot of problem

          smithgcovert smithgcovert added a comment - Created an attachment (id=360) screenshot of problem
          drulli Ulli Hafner added a comment -

          Did you upgrade from 1.10 to 1.11? Are there any errors in Hudsons log?

          drulli Ulli Hafner added a comment - Did you upgrade from 1.10 to 1.11? Are there any errors in Hudsons log?
          smithgcovert smithgcovert added a comment -

          Hi,

          Yes, the upgrade was from 1.10 to 1.11. There are no errors in the log, but
          there are several INFO messages related to the Warning plugin – but they all
          look OK:

          Aug 28, 2008 9:09:46 AM hudson.plugins.warnings.util.AnnotationsBuildResult
          loadResult
          INFO: Loaded data file
          /builds.hudson/hudson/jobs/Zero-Build/builds/2008-08-28_03-28-46/compiler-warnings.xml
          for build 254

          Aug 28, 2008 9:09:46 AM hudson.plugins.warnings.util.AnnotationsBuildResult
          loadResult
          INFO: Loaded data file
          /builds.hudson/hudson/jobs/Zero-Build/builds/2008-08-28_05-25-34/compiler-warnings.xml
          for build 255

          Today as soon as a window opens I am going to go back to 1.10 and I will let you
          know the result of moving back.

          Another possibility that the problem was caused by the new GCC warning support.
          Our build compiles some code on both Mac and Linux, and that code has warnings
          that appear in both. (cc and gcc, respectively.) The code is the same for
          both, perhaps it is confused by the same warnings being in the console log twice
          but slightly differently. Linux is compiled via an jsch SSH session.

          We do a similar remote compile for Microsoft too – although MS compiler
          warnings were working OK before the upgrade.

          I am attaching a compiler-warnings.xml file from the last run, in case that
          might help.

          Thanks much.

          smithgcovert smithgcovert added a comment - Hi, Yes, the upgrade was from 1.10 to 1.11. There are no errors in the log, but there are several INFO messages related to the Warning plugin – but they all look OK: Aug 28, 2008 9:09:46 AM hudson.plugins.warnings.util.AnnotationsBuildResult loadResult INFO: Loaded data file /builds.hudson/hudson/jobs/Zero-Build/builds/2008-08-28_03-28-46/compiler-warnings.xml for build 254 Aug 28, 2008 9:09:46 AM hudson.plugins.warnings.util.AnnotationsBuildResult loadResult INFO: Loaded data file /builds.hudson/hudson/jobs/Zero-Build/builds/2008-08-28_05-25-34/compiler-warnings.xml for build 255 Today as soon as a window opens I am going to go back to 1.10 and I will let you know the result of moving back. Another possibility that the problem was caused by the new GCC warning support. Our build compiles some code on both Mac and Linux, and that code has warnings that appear in both. (cc and gcc, respectively.) The code is the same for both, perhaps it is confused by the same warnings being in the console log twice but slightly differently. Linux is compiled via an jsch SSH session. We do a similar remote compile for Microsoft too – although MS compiler warnings were working OK before the upgrade. I am attaching a compiler-warnings.xml file from the last run, in case that might help. Thanks much.
          smithgcovert smithgcovert added a comment -

          Created an attachment (id=361)
          Sample compiler-warnings file

          smithgcovert smithgcovert added a comment - Created an attachment (id=361) Sample compiler-warnings file
          drulli Ulli Hafner added a comment -

          I found it, again a copy paste error. I really need to move the common code of
          my plug-ins into a separate project...

          In the meantime you could either install the checkstyle plugin or change the
          file Y:\Build\Workspace\plugins\warnings\WEB-INF\classes\tabview\main.jelly.
          Replace checkstyle with warnings!

          <script type="text/javascript"
          src="${rootURL}/plugin/checkstyle/yui/utilities.js"></script>
          <script type="text/javascript"
          src="${rootURL}/plugin/checkstyle/yui/tabview-min.js"></script>
          <script type="text/javascript"
          src="${rootURL}/plugin/checkstyle/yui/dispatcher-min.js"></script>

          drulli Ulli Hafner added a comment - I found it, again a copy paste error. I really need to move the common code of my plug-ins into a separate project... In the meantime you could either install the checkstyle plugin or change the file Y:\Build\Workspace\plugins\warnings\WEB-INF\classes\tabview\main.jelly. Replace checkstyle with warnings! <script type="text/javascript" src="${rootURL}/plugin/checkstyle/yui/utilities.js"></script> <script type="text/javascript" src="${rootURL}/plugin/checkstyle/yui/tabview-min.js"></script> <script type="text/javascript" src="${rootURL}/plugin/checkstyle/yui/dispatcher-min.js"></script>
          smithgcovert smithgcovert added a comment -

          Hi,

          Moved back to 1.10, and that is working for me. When the next level comes out,
          I'll update.

          Glad it was something easy to find.

          smithgcovert smithgcovert added a comment - Hi, Moved back to 1.10, and that is working for me. When the next level comes out, I'll update. Glad it was something easy to find.

          Code changed in hudson
          User: : drulli
          Path:
          trunk/hudson/plugins/findbugs/src/main/resources/tabview/main.jelly
          trunk/hudson/plugins/pmd/src/main/resources/tabview/main.jelly
          trunk/hudson/plugins/tasks/src/main/resources/tabview/main.jelly
          trunk/hudson/plugins/warnings/src/main/resources/tabview/main.jelly
          http://fisheye4.cenqua.com/changelog/hudson/?cs=11805
          Log:
          [FIXED JENKINS-2284] Fixed wrong path to YUI components.

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : drulli Path: trunk/hudson/plugins/findbugs/src/main/resources/tabview/main.jelly trunk/hudson/plugins/pmd/src/main/resources/tabview/main.jelly trunk/hudson/plugins/tasks/src/main/resources/tabview/main.jelly trunk/hudson/plugins/warnings/src/main/resources/tabview/main.jelly http://fisheye4.cenqua.com/changelog/hudson/?cs=11805 Log: [FIXED JENKINS-2284] Fixed wrong path to YUI components.

          People

            drulli Ulli Hafner
            smithgcovert smithgcovert
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: