Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24465

docker-build-step 1.9 non-functional in Free-style build job

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • None
    • Linux amd64 + OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1)
      Jenkins 1.565.1
      docker-build-step 1.9

      Docker 1.01 API 1.12 on remote host

    Description

      Starting with docker-build-step 1.9, the plug-in is non-functional at least in free style build jobs (as I assume this version was somehow tested before release, it may work in other job types).

      Error message:

      FATAL: Unable to serialize org.jenkinsci.plugins.dockerbuildstep.DockerBuilder$DockerCmdCallable@48869354
      java.io.IOException: Unable to serialize org.jenkinsci.plugins.dockerbuildstep.DockerBuilder$DockerCmdCallable@48869354
      at hudson.remoting.UserRequest.serialize(UserRequest.java:166)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:62)
      at hudson.remoting.Channel.call(Channel.java:738)
      at org.jenkinsci.plugins.dockerbuildstep.DockerBuilder.perform(DockerBuilder.java:67)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:756)
      at hudson.model.Build$BuildExecution.build(Build.java:198)
      at hudson.model.Build$BuildExecution.doRun(Build.java:159)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      at hudson.model.Run.execute(Run.java:1706)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:232)
      Caused by: java.io.NotSerializableException: hudson.model.FreeStyleBuild
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1183)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1547)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1508)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1431)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1177)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:347)
      at hudson.remoting.UserRequest._serialize(UserRequest.java:155)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:164)
      ... 12 more

      Attachments

        Issue Links

          Activity

            jks Julian Kassat added a comment -

            Fixed in docker-build-step 1.10

            jks Julian Kassat added a comment - Fixed in docker-build-step 1.10

            People

              vjuranek vjuranek
              jks Julian Kassat
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: