Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31536

Jobs hanging in Build Executor even if it is finished

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Done
    • core

    Description

      Since a couple of days (since updating to 1.609.3 LTS) we have the problem that is the builds stick in the bild executor.If you open the build details the build is finished allready. But the executor is still blocked leading to a Build-queue that is constantly growing. Sometime the executor will display "DEAD " (German: "Tot "). There are no specific entries in the log file.

      Master is running on a virtual Windows Server 2012. Slaves are Windoes Server 2012 and Windows 7.

      Attachments

        1. BuildExecutors.png
          BuildExecutors.png
          80 kB
        2. jenkins_dump.txt
          451 kB
        3. jenkins-plugins.txt
          3 kB
        4. Thread Dump [Jenkins].pdf
          288 kB

        Issue Links

          Activity

            ark_jenkins Jenkins Ark added a comment -

            Same problem.

            Seems like this problem happens after upgrading to 2.164.1

            After downgrade to 2.150.3 everything is fine.

             

            ark_jenkins Jenkins Ark added a comment - Same problem. Seems like this problem happens after upgrading to 2.164.1 After downgrade to 2.150.3 everything is fine.  
            danielbeck Daniel Beck added a comment -

            Since you all are contradicting each other, you're making further investigation impossible. Why bother commenting at all? Please file new issues and provide information beyond version number. Some ideas: https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue

            danielbeck Daniel Beck added a comment - Since you all are contradicting each other, you're making further investigation impossible. Why bother commenting at all? Please file new issues and provide information beyond version number. Some ideas: https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue
            ark_jenkins Jenkins Ark added a comment -

            Sorry for the unclear comment. My bad!

            Actually after some test I found that downgrade to 2.150.3 CANNOT solve the problem. 

             

            ark_jenkins Jenkins Ark added a comment - Sorry for the unclear comment. My bad! Actually after some test I found that downgrade to 2.150.3 CANNOT solve the problem.   
            ark_jenkins Jenkins Ark added a comment - - edited

            FYI the problem occurs at a Windows machine, after some investigation I found that the master(Linux machine) failed to ping the Windows slave (time out). Although the master can successfully ping the slave.

            So I turn on the ping access on the Windows Firewall, and the problem is gone!

             

            Below is a piece of the SystemInfo of the Windows slave that inspired me:

            Ping thread for channel hudson.remoting.Channel@432d3ea4:JNLP4-connect connection to 10.5.57.xxx/10.5.57.xxx:59095

            "Ping thread for channel hudson.remoting.Channel@432d3ea4:JNLP4-connect connection to 10.5.57.xxx/10.5.57.xxx:59095" Id=28 Group=main TIMED_WAITING at java.lang.Thread.sleep(Native Method) at hudson.remoting.PingThread.run(PingThread.java:95)

             

            ark_jenkins Jenkins Ark added a comment - - edited FYI the problem occurs at a Windows machine, after some investigation I found that the master(Linux machine) failed to ping the Windows slave (time out). Although the master can successfully ping the slave. So I turn on the ping access on the Windows Firewall, and the problem is gone!   Below is a piece of the SystemInfo of the Windows slave that inspired me: Ping thread for channel hudson.remoting.Channel@432d3ea4:JNLP4-connect connection to 10.5.57.xxx/10.5.57.xxx:59095 "Ping thread for channel hudson.remoting.Channel@432d3ea4:JNLP4-connect connection to 10.5.57.xxx/10.5.57.xxx:59095" Id=28 Group=main TIMED_WAITING at java.lang.Thread.sleep(Native Method) at hudson.remoting.PingThread.run(PingThread.java:95)  
            ark_jenkins Jenkins Ark added a comment -

            FYI. Turn on the ping access on the Windows slave DONOT solve the problem. It was an illusion.....

            ark_jenkins Jenkins Ark added a comment - FYI. Turn on the ping access on the Windows slave DONOT solve the problem. It was an illusion.....

            People

              Unassigned Unassigned
              herrmann81 Stefan Herrmann
              Votes:
              6 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: