Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31859

Jenkins pipeline displaying wrong result

    XMLWordPrintable

Details

    Description

      We have implemented jenkins pipelines. It has several builds chained together. The second to last build triggers three parellel jobs if the build suceeds. Two of these jobs fail but the result of the builds are shown as success.

      I've included two screen shots. One showing the build pipeline as green but the seperate builds are red. The build logs also report the build is failed.

      Attachments

        1. pipeline.PNG
          37 kB
          Josip Juric
        2. profile_build.PNG
          20 kB
          Josip Juric

        Activity

          rtyler R. Tyler Croy added a comment -

          I've moved this to the JENKINS project, the WEBSITE project is for tickets pertaining to the jenkins-ci.org website

          rtyler R. Tyler Croy added a comment - I've moved this to the JENKINS project, the WEBSITE project is for tickets pertaining to the jenkins-ci.org website

          josipj What version are you using?

          recena Manuel Recena Soto added a comment - josipj What version are you using?
          josipj Josip Juric added a comment -

          We're using jenkins version 1.596.2

          josipj Josip Juric added a comment - We're using jenkins version 1.596.2

          josipj I meant plugin version.

          recena Manuel Recena Soto added a comment - josipj I meant plugin version.
          josipj Josip Juric added a comment -

          The build pipeline plugin version we are using is 1.4.7

          josipj Josip Juric added a comment - The build pipeline plugin version we are using is 1.4.7

          josipj It would be interesting to try if 1.4.9 version solves the problem.

          recena Manuel Recena Soto added a comment - josipj It would be interesting to try if 1.4.9 version solves the problem.
          dalvizu Dan Alvizu added a comment -

          There were issues in upstream/downstream relationship between 1.4.7 and 1.4.9 - please upgrade and re-test.

          I have this exact scenario and cannot reproduce.

          If you are able to reproduce, please include more information about your setup:

          How does the second job trigger the three jobs? If you can include the config.xml that would be great, but barring that:

          1) Are you using 'build other projects', 'manual trigger', 'trigger paramterized projects', and if so what version of the parameterized tirgger plugin are you running?
          2) What are you doing in the jobs which are failing yet show up as success? Can you include the config.xml of those jobs?

          dalvizu Dan Alvizu added a comment - There were issues in upstream/downstream relationship between 1.4.7 and 1.4.9 - please upgrade and re-test. I have this exact scenario and cannot reproduce. If you are able to reproduce, please include more information about your setup: How does the second job trigger the three jobs? If you can include the config.xml that would be great, but barring that: 1) Are you using 'build other projects', 'manual trigger', 'trigger paramterized projects', and if so what version of the parameterized tirgger plugin are you running? 2) What are you doing in the jobs which are failing yet show up as success? Can you include the config.xml of those jobs?

          People

            recena Manuel Recena Soto
            josipj Josip Juric
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: