Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32395

Exception thrown when TFS plugin does SCM polling to TFS (on Jenkins version 1.643)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Component/s: tfs-plugin
    • Labels:
    • Environment:
      Jenkins version 1.643,
      TFS version 4.0.0
      Mailer version 1.16 (same with version 1.11)
      java.runtime.version 1.8.0_11-b12
      Mac OS X 10.11.2
    • Similar Issues:

      Description

      Here is the error shown in the logs (not that it also occur from time to time when I manually launch the build.).

      Jan 11, 2016 1:28:01 PM SEVERE hudson.triggers.SCMTrigger$Runner runPolling
      Failed to record SCM polling for hudson.model.FreeStyleProject@3ad7e6a5[BuildIPadForTestFairy]
      java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
      at hudson.plugins.tfs.model.Project.getOrCreateUserLookup(Project.java:112)
      at hudson.plugins.tfs.model.Project.getVCCHistory(Project.java:81)
      at hudson.plugins.tfs.model.Project.getLatestChangeset(Project.java:165)
      at hudson.plugins.tfs.TeamFoundationServerScm.compareRemoteRevisionWith(TeamFoundationServerScm.java:498)
      at hudson.scm.SCM.poll(SCM.java:398)
      at hudson.model.AbstractProject._poll(AbstractProject.java:1453)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1356)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:526)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:555)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:119)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      ... 15 more

        Attachments

          Activity

          kelliejos Kellie Jos added a comment -

          Thank you for using the tfs-plugin. It appears that your issue was found in an older version of the plugin. There have been a number of improvements made in the recent releases that may have resolved your issue. Please update to the most recent 5.126.0 release. If your issue persists, please open a new ticket and we will investigate.


            People

            Assignee:
            dastahel David Staheli
            Reporter:
            pathuot patrice huot
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: