Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33116

Not logging in on new slave agent in kubernetes.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Labels:
      None
    • Environment:
      Kubernetes master slave configuration. Registry is a private registry (v2).
    • Similar Issues:

      Description

      This plugin will not log in when a slave agent goes down and another one replaces it. You must manually bash into the agent and run "docker login" to get it to work again.

      Upon further testing, it looks like registry auth is not working at all:
      docker-build-publish 1.2
      docker-commons 1.3.1 (required for "sha256" prefix required in new version of docker)

      Attempts to publish get:
      unauthorized: authentication required

      If you run docker login manually from bash and the credentials get stored in .docker/config.json then it will start working, but I will not login on it's own. I've confirmed that the username and password we have set in credentials is correct.

        Attachments

          Activity

          Hide
          mrichar2 Mark R added a comment -

          I am also hitting this issue.

          Show
          mrichar2 Mark R added a comment - I am also hitting this issue.

            People

            Assignee:
            csanchez Carlos Sanchez
            Reporter:
            pjchen PJ Chen
            Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: