Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33187

Manual Job Trigger Broken when triggering from Build Pipeline Plugin

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Duplicate
    • build-pipeline-plugin
    • None
    • Manual Job Trigger Broken in Pipeline v1.5.1 with Jenkins 1.642.1

      OS = Centos7

    Description

      When Creating a manual trigger downstream of a pipeline flow, I get the attached error in the log when trying to trigger the manual step and the job never starts.

      Attachments

        Issue Links

          Activity

            dalvizu Dan Alvizu added a comment -

            It looks like the root cause is:

            `java.lang.IllegalStateException: No upstream trigger found for this projectPolicy Judge » AcceptanceTest2`

            It looks like you are using the cloudbees folder plugin. Check you upstream config and make sure that you specify the fully qualified path, including folders. You are likely giving the relative name and it is not found

            dalvizu Dan Alvizu added a comment - It looks like the root cause is: `java.lang.IllegalStateException: No upstream trigger found for this projectPolicy Judge » AcceptanceTest2` It looks like you are using the cloudbees folder plugin. Check you upstream config and make sure that you specify the fully qualified path, including folders. You are likely giving the relative name and it is not found

            Closing as duplicate of JENKINS-23532 since that bug is older and has more information then this one.

            dserodio Daniel Serodio added a comment - Closing as duplicate of JENKINS-23532 since that bug is older and has more information then this one.

            People

              Unassigned Unassigned
              madams Matthew Adams
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: