Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38484

Using test stability publisher in a Pipeline build will hang

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: test-stability-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.23
      Pipeline 2.4
      Test Stability 1.0
    • Similar Issues:

      Description

      Using the test stability publisher with the JUnit plugin will hang a Pipeline build.

      To reproduce:

      node {
        writeFile text: '<testsuite><testcase name="bar" classname="FooTest" time="0.001"/></testsuite>', file: 'results.xml'
        junit testResults: '**/*.xml', testDataPublishers: [[$class: 'StabilityTestDataPublisher']]
      }
      

      I couldn't see anything related in the build thread dump, or the agent thread dump.
      But this looks related to work Andrew Bayer has done for JENKINS-28784 and JENKINS-26535.

        Attachments

          Activity

          seanf Sean Flanigan added a comment -

          kutzi It might take me a little while to finish JENKINS-33168, so in the meantime I'd like to go ahead and release this, unless you want to do it.

          Should I request to become maintainer, or to become a second maintainer? Or is it possible for me to make a release without being considered a maintainer?

          I see that there are no developers currently listed here (probably because you hadn't made a release for a while when they created the yml-based system): https://github.com/jenkins-infra/repository-permissions-updater/blob/master/permissions/plugin-test-stability.yml

          kutzi kutzi added a comment -

          I'm not sure, but I think you cannot do a release without being a maintainer.
          Please go forward and request becoming an maintainer for this project, if you like to.
          Thank you for your work on this issue!

          seanf Sean Flanigan added a comment -

          kutzi For the release notes/wiki page, I suppose I could say that the 2.0 version bump is because the test-stability plugin now requires Jenkins 1.596, and also the Additional test report features (fixed) section could be removed. Would you agree with that?

          kutzi kutzi added a comment -

          Yes, +1

          seanf Sean Flanigan added a comment - - edited

          Test-stability plugin 2.2 * has now been released with this fix. Thanks for the report Christopher Orr, and for the fix Dominik Bruhn! EDIT: Thanks for the support kutzi.

          * Why not version 2.0, you ask? Because Maven.


            People

            Assignee:
            seanf Sean Flanigan
            Reporter:
            orrc Christopher Orr
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: