Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38677

Failure to create label in TFS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Component/s: tfs-plugin
    • Labels:
    • Environment:
      Windows 2012 Jenkins 2.24 tfs-plugin 5.2.1
    • Similar Issues:

      Description

      Since upgrading to 5.2.1 of the TFS plugin bad things have started happening: Last step in job is to apply label to TFS if all unit tests pass. Instead I get this more often than not:

      Creating label 'TPS_1927' on '$/PSD Team/TPS/TPS App' as of the current version in workspace 'Hudson-TPS-MASTER'...
      ERROR: Build step failed with exception
      java.lang.RuntimeException: java.lang.RuntimeException: Label creation failed.
      at hudson.plugins.tfs.model.Server.execute(Server.java:226)
      at hudson.plugins.tfs.TFSLabeler.perform(TFSLabeler.java:86)
      at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:32)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:404)
      Caused by: java.lang.RuntimeException: Label creation failed.
      at hudson.plugins.tfs.commands.LabelCommand.call(LabelCommand.java:70)
      at hudson.plugins.tfs.commands.LabelCommand.call(LabelCommand.java:22)
      at hudson.remoting.LocalChannel.call(LocalChannel.java:45)
      at hudson.plugins.tfs.model.Server.execute(Server.java:222)
      ... 10 more

      This is REALLY BAD as we rely on labels to deploy by label via Web Deploy.

        Attachments

          Activity

          apgray Andrew Gray added a comment -

          I will add that this error seems to occur in this corporate environment where it will intermittently effect builds for a couple of days at a time and then I'll get a sequence of days where the problem goes away completely only to return later.

          kelliejos Kellie Jos added a comment -

          Thank you for using the tfs-plugin. It appears that your issue was found in an older version of the plugin. There have been a number of improvements made in the recent releases that may have resolved your issue. Please update to the most recent 5.126.0 release. If your issue persists, please open a new ticket and we will investigate.


            People

            Assignee:
            redsolo redsolo
            Reporter:
            apgray Andrew Gray
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: