Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39025

Pull request from forks are not build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Github Enterprise, Jenkins 2.6, github-branch-source 1.10
    • Similar Issues:

      Description

      We have enabled the Build fork PRs (merged with base branch) option in our Job for the Github organisation we have, however, when we create a pull request based from a fork, no build is triggered.

      This seems to be caused by the hook settings, which are just Push and Repository. Push doesn't seem to trigger when the PR is created, and as such the build is never created from the PR.

      When we add the Pull Request event in our github configuration, there build is created correctly.

        Attachments

          Issue Links

            Activity

            elgalu Leo Gallucci added a comment -

            +1 , in the end I had to enable "send me everything" in the web hook.

            docwhat Christian Höltje added a comment -

            I think correct events are: push, repository, and pull-request

            But I'm not positive, because it seems like the GitHub Org. Folder no longer creates/updates hooks anymore; possibly due to the transition from a separate plugin?

            stephenconnolly Stephen Connolly added a comment -

            Root cause is the webhook not being configured correctly, which probably is a result of the duplication of configurations and all the crazy that results from the duplication


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              paulsohier Paul Sohier
              Votes:
              4 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: