Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39309

gherkin.deps.com.google.gson.stream.MalformedJsonException: Expected EOF at line 11061 column 8

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Incomplete
    • None
    • cucumber-testresult-plugin 0.9.7
      Jenkins ver. 2.27

    Description

      [Cucumber Tests] Parsing results.
      [Cucumber Tests] parsing cucumber.json
      ERROR: Build step failed with exception
      gherkin.deps.com.google.gson.JsonSyntaxException: gherkin.deps.com.google.gson.stream.MalformedJsonException: Expected EOF at line 11061 column 8
      at gherkin.deps.com.google.gson.Gson.assertFullConsumption(Gson.java:772)
      at gherkin.deps.com.google.gson.Gson.fromJson(Gson.java:735)
      at gherkin.JSONParser.parse(JSONParser.java:41)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberJSONParser.parse(CucumberJSONParser.java:78)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberJSONParser.parse(CucumberJSONParser.java:44)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.DefaultTestResultParserImpl$ParseResultCallable.invoke(DefaultTestResultParserImpl.java:161)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.DefaultTestResultParserImpl$ParseResultCallable.invoke(DefaultTestResultParserImpl.java:107)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2731)
      at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      at hudson.remoting.Request$2.run(Request.java:332)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      at ......remote call to c4.8xlarge (i-35807bba)(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1435)
      at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
      at hudson.remoting.Channel.call(Channel.java:795)
      at hudson.FilePath.act(FilePath.java:985)
      at hudson.FilePath.act(FilePath.java:974)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.DefaultTestResultParserImpl.parseResult(DefaultTestResultParserImpl.java:101)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberJSONParser.parseResult(CucumberJSONParser.java:101)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberTestResultArchiver.publishReport(CucumberTestResultArchiver.java:128)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberTestResultArchiver.perform(CucumberTestResultArchiver.java:107)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1067)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665)
      at hudson.model.Run.execute(Run.java:1745)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:544)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:401)
      Caused by: gherkin.deps.com.google.gson.stream.MalformedJsonException: Expected EOF at line 11061 column 8
      at gherkin.deps.com.google.gson.stream.JsonReader.syntaxError(JsonReader.java:1310)
      at gherkin.deps.com.google.gson.stream.JsonReader.peek(JsonReader.java:390)
      at gherkin.deps.com.google.gson.Gson.assertFullConsumption(Gson.java:768)
      at gherkin.deps.com.google.gson.Gson.fromJson(Gson.java:735)
      at gherkin.JSONParser.parse(JSONParser.java:41)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberJSONParser.parse(CucumberJSONParser.java:78)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberJSONParser.parse(CucumberJSONParser.java:44)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.DefaultTestResultParserImpl$ParseResultCallable.invoke(DefaultTestResultParserImpl.java:161)
      at org.jenkinsci.plugins.cucumber.jsontestsupport.DefaultTestResultParserImpl$ParseResultCallable.invoke(DefaultTestResultParserImpl.java:107)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2731)
      at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      at hudson.remoting.Request$2.run(Request.java:332)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)

      Attachments

        Activity

          teilo James Nord added a comment -

          No possible way to reproduce the issue unless you attach a the generated json file as a minimum and better a sample minimum project that shows the issue.

          teilo James Nord added a comment - No possible way to reproduce the issue unless you attach a the generated json file as a minimum and better a sample minimum project that shows the issue.
          teilo James Nord added a comment -

          Basically the json is invalid at the json level before it even gets to the gherkin level

          teilo James Nord added a comment - Basically the json is invalid at the json level before it even gets to the gherkin level

          People

            Unassigned Unassigned
            emoshaya_cognitoiq Ebrahim Moshaya
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: