Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40860

Go to the end of the expanded log

    XMLWordPrintable

    Details

    • Similar Issues:
    • Sprint:
      pannonian, iapetus, 1.0

      Description

      When clicking a failed stage (or directly going to it), the log does not scroll to the end, which is presumably where you could see an error.

      Noticed on ci: https://ci.blueocean.io/blue/organizations/jenkins/Pipeline%20Editor/detail/PR-15/1/pipeline/11

        Attachments

          Issue Links

            Activity

            kzantow Keith Zantow created issue -
            jamesdumay James Dumay made changes -
            Field Original Value New Value
            Issue Type Improvement [ 4 ] Bug [ 1 ]
            Priority Major [ 3 ] Critical [ 2 ]
            jamesdumay James Dumay made changes -
            Sprint release candidate [ 171 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Epic Link JENKINS-35750 [ 171713 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint release candidate [ 171 ] iapetus [ 216 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Assignee Tom FENNELLY [ tfennelly ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint iapetus [ 216 ] pannonian [ 211 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Assignee Tom FENNELLY [ tfennelly ] Thorsten Scherler [ tscherler ]
            tscherler Thorsten Scherler made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            tscherler Thorsten Scherler added a comment - - edited
            tscherler Thorsten Scherler made changes -
            Status In Progress [ 3 ] Open [ 1 ]
            kzantow Keith Zantow added a comment -
            tscherler Thorsten Scherler made changes -
            tscherler Thorsten Scherler added a comment -

            Is what I see for that link.

            chasing the dragon https://www.youtube.com/watch?v=uBVkk5rW0lw

            tscherler Thorsten Scherler made changes -
            Labels feedback for waiting
            tscherler Thorsten Scherler made changes -
            Labels feedback for waiting waiting4feedback
            jamesdumay James Dumay made changes -
            Sprint pannonian [ 211 ] pannonian, iapetus [ 211, 216 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            michaelneale Michael Neale made changes -
            Link This issue is blocked by JENKINS-38523 [ JENKINS-38523 ]
            michaelneale Michael Neale made changes -
            Sprint pannonian, iapetus [ 211, 216 ] pannonian [ 211 ]
            michaelneale Michael Neale made changes -
            Sprint pannonian [ 211 ] pannonian, panthalassa [ 211, 221 ]
            michaelneale Michael Neale made changes -
            Rank Ranked higher
            michaelneale Michael Neale made changes -
            Assignee Thorsten Scherler [ tscherler ] Michael Neale [ michaelneale ]
            michaelneale Michael Neale made changes -
            Priority Critical [ 2 ] Major [ 3 ]
            michaelneale Michael Neale added a comment -

            I tried, but can't reproduce this. I made a long pipeline log with a failing step - and it jumped to it.

            If there is another example we can record a video of - should do it, but we can park this for now (I suspect there is some race condition)

            michaelneale Michael Neale made changes -
            Priority Major [ 3 ] Minor [ 4 ]
            michaelneale Michael Neale made changes -
            Sprint pannonian, panthalassa [ 211, 221 ] release candidate, pannonian [ 171, 211 ]
            michaelneale Michael Neale made changes -
            Assignee Michael Neale [ michaelneale ]
            jamesdumay James Dumay made changes -
            Sprint release candidate, pannonian [ 171, 211 ] pannonian, panthalassa [ 211, 221 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Assignee Thorsten Scherler [ tscherler ]
            jamesdumay James Dumay made changes -
            Sprint pannonian, panthalassa [ 211, 221 ] pannonian, iapetus [ 211, 216 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            michaelneale Michael Neale made changes -
            Sprint pannonian, iapetus [ 211, 216 ] pannonian [ 211 ]
            michaelneale Michael Neale made changes -
            Sprint pannonian [ 211 ] pannonian, panthalassa [ 211, 221 ]
            michaelneale Michael Neale made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint pannonian, panthalassa [ 211, 221 ] pannonian, iapetus [ 211, 216 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint pannonian, iapetus [ 211, 216 ] pannonian, iapetus, 1.0 [ 211, 216, 221 ]
            jamesdumay James Dumay added a comment -

            I think you were able to reproduce with the Jenkinsfile below but it seems to have been fixed.

            node {
               try {
                 stage('first') {
                     sh 'ls ../ && exit 1'
                 }
               } finally {
                 stage('second') {
                     sh 'ls ../ && exit 1'
                 }
               }
            }
            
            jamesdumay James Dumay made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Resolved [ 5 ]
            jbriden Jenn Briden made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              Assignee:
              tscherler Thorsten Scherler
              Reporter:
              kzantow Keith Zantow
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: