Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41790

GitHub organization Webhook is not re-registered after deleting webhook on github

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      OS: Ubuntu 14.04
      Jenkins: docker container (jenkins:2.32.2)
      Plugin version: 2.0.1
    • Similar Issues:

      Description

      The following is the reproducing steps.

      1. Create a GitHub organization folder
      2. Delete the folder
      3. Delete the org's webhook on GitHub
      4. Create the GitHub organization folder again
      -> Webhook is not registered on GitHub

      It is because the existence of webhook is managed on Jenkins master as a file.

      https://github.com/jenkinsci/github-branch-source-plugin/blob/github-branch-source-2.0.1/src/main/java/org/jenkinsci/plugins/github_branch_source/GitHubOrgWebHook.java#L104

      But I think it is not good idea. It seems that the existence of webhook can be checked by looking at urls of org's webhook.

        Attachments

          Issue Links

            Activity

            stephenconnolly Stephen Connolly added a comment -

            Merging with JENKINS-37845


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              miyajan Miyata Jumpei
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: