Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44315

Tests with names too long for filenames cause issues with test reporting

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: nunit-plugin
    • Labels:
      None
    • Environment:
      Slave Windows 10, Master Windows 2012
    • Similar Issues:

      Description

      We updated the nunit and we can't generate anymore the nunit2 format, so we moved on to the new nunit3 format, but now the publishing of the nunit result is broken.

        Attachments

          Activity

          sbhanderi sunil bhanderi added a comment - - edited

          Tests were run on agent. on VMs.

           

          slide_o_mix Alex Earl added a comment -

          I have been unable to reproduce this. Are you still seeing the issue?

          sbhanderi sunil bhanderi added a comment - - edited

          Hi Alex,

          Yes I am still getting this error. maybe 3 times out of 30 times each week.

          If you could you give me instructions how to debug then that would help. Maybe we can trap where the problem is located.

          I will try to upload another xml file if that helps.

          slide_o_mix Alex Earl added a comment -

          sunil bhanderi I don't think your issue is related to what was originally posted in this issue. I think this specific issue was because the test names were too long. I think your issue is something else. Can you file a new issue please and we'll close this one out?

          slide_o_mix Alex Earl added a comment -

          Fixed in 0.22 which will be released soon.


            People

            Assignee:
            slide_o_mix Alex Earl
            Reporter:
            spamme spam me
            Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: