Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47395

Github Server must have /api/v3 appended

    XMLWordPrintable

Details

    • Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 5

    Description

      Problem
      User has to know to add /api/v3 to the end of their server URL

      Steps to reproduce

      1. Go to Creation
      2. Click Github Enterprise
      3. Cick Add server
      4. Provide a name for the server
      5. Provide the URL to Github Enterprise

      What you see
      Blue Ocean cannot connect to Github Enterprise

      What should happen
      Blue Ocean should automatically append /api/v3 to the server URL if not already specified.

      Attachments

        1. ghe.png
          134 kB
          James Dumay

        Issue Links

          Activity

            kshultz Karl Shultz added a comment -

            Testing notes:

            • A "live" automated test could be added, which adds a GitHub Enterprise server URL without appending api/v3 to the end. This way, each time the test is run, this would be covered.
            • In the future, if the end of the URL changes to api/v4 (or some other, similar change), test failures would let us know about it pretty quickly.
            kshultz Karl Shultz added a comment - Testing notes : A "live" automated test could be added, which adds a GitHub Enterprise server URL without appending api/v3 to the end. This way, each time the test is run, this would be covered. In the future, if the end of the URL changes to api/v4 (or some other, similar change), test failures would let us know about it pretty quickly.
            nicu Nicolae Pascu added a comment -

            kshultz From what I can see in the ATH live tests we do not have an actual GHE server to connect to, we mock it, so this would not actually catch an URL change in actual GHE servers. I left the current behaviour of trying to connect to the URL provided by the user and in case that fails, re-try with the URL appended by "/api/v3", this should cover all cases until a URL changes in GHE, in which point adding GHE servers will still work as long as the user knows the correct URL

            nicu Nicolae Pascu added a comment - kshultz From what I can see in the ATH live tests we do not have an actual GHE server to connect to, we mock it, so this would not actually catch an URL change in actual GHE servers. I left the current behaviour of trying to connect to the URL provided by the user and in case that fails, re-try with the URL appended by "/api/v3", this should cover all cases until a URL changes in GHE, in which point adding GHE servers will still work as long as the user knows the correct URL

            Problem reproduced with kshultz on Blue Ocean 1.4.2 / Jenkins Core 2.89.4

            I had to suffix my github enterprise url by /api/v3 to workaround.

            cleclerc Cyrille Le Clerc added a comment - Problem reproduced with kshultz on Blue Ocean 1.4.2 / Jenkins Core 2.89.4 I had to suffix my github enterprise url by /api/v3 to workaround.
            nicu Nicolae Pascu added a comment -

            cleclerc kshultz The fix was not cherry picked from master to the 1.4 release branch and that is why the bug is still present in 1.4.2. I cherry picked it via a PR today and it will be present in the next release.

            nicu Nicolae Pascu added a comment - cleclerc kshultz The fix was not cherry picked from master to the 1.4 release branch and that is why the bug is still present in 1.4.2. I cherry picked it via a PR today and it will be present in the next release.

            People

              nicu Nicolae Pascu
              jamesdumay James Dumay
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: