Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49421

JNLP4-connect connection from xxx.xxx.xxx.xxx failed after the success of build procedure

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Cannot Reproduce
    • remoting
    • None
    • jenkins version : 2.73.3
      OS : MacOS
      Jenkins master : Centos 7

    Description

      Hi,

      I got a failure after all the build procedure were finished without any errors.

      And I don't know why below error has occurred.

      This error has marked the status of a job as a failure even all the tests were successfully finished.
      FATAL: Remote call on JNLP4-connect connection from 10.70.25.27/10.70.25.27:58008 failed

       
      19:17:12 [ 87%] /sdcard/screen_record_13.mp4

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,23619:17:12 [ 92%] /sdcard/screen_record_13.mp4

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,23719:17:12 [ 96%] /sdcard/screen_record_13.mp4

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,23819:17:12 [100%] /sdcard/screen_record_13.mp4

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,23919:17:12 /sdcard/screen_record_13.mp4: 1 file pulled. 26.4 MB/s (1421277 bytes in 0.051s)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24019:17:22 Process leaked file descriptors. See https://jenkins.io/redirect/troubleshooting/process-leaked-file-descriptors for more information

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24119:17:22 Set build name.

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24219:17:22 New build name is '#61_HT7BR1A05058_4723'

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24319:17:22 Variable with name 'BUILD_DISPLAY_NAME' already exists, current value: '#61_HT7BR1A05058_4723', new value: '#61_HT7BR1A05058_4723'

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24419:17:22 FATAL: Remote call on JNLP4-connect connection from 10.70.25.27/10.70.25.27:64384 failed

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24519:17:22 java.lang.NoClassDefFoundError: Could not initialize class hudson.util.ProcessTree$UnixReflection

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24619:17:22 at hudson.util.ProcessTree$UnixProcess.kill(ProcessTree.java:647)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24719:17:22 at hudson.util.ProcessTree$UnixProcess.killRecursively(ProcessTree.java:668)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24819:17:22 at hudson.util.ProcessTree$UnixProcess.killRecursively(ProcessTree.java:667)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,24919:17:22 at hudson.util.ProcessTree$Unix.killAll(ProcessTree.java:589)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25019:17:22 at hudson.Launcher$RemoteLauncher$KillTask.call(Launcher.java:1091)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25119:17:22 at hudson.Launcher$RemoteLauncher$KillTask.call(Launcher.java:1082)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25219:17:22 at hudson.remoting.UserRequest.perform(UserRequest.java:208)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25319:17:22 at hudson.remoting.UserRequest.perform(UserRequest.java:54)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25419:17:22 at hudson.remoting.Request$2.run(Request.java:360)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25519:17:22 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25619:17:22 at java.util.concurrent.FutureTask.run(FutureTask.java:264)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25719:17:22 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25819:17:22 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,25919:17:22 at hudson.remoting.Engine$1$1.run(Engine.java:98)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26019:17:22 at java.lang.Thread.run(Thread.java:844)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26119:17:22 at ......remote call to JNLP4-connect connection from 10.70.25.27/10.70.25.27:64384(Native Method)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26219:17:22 at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1654)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26319:17:22 at hudson.remoting.UserResponse.retrieve(UserRequest.java:311)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26419:17:22 at hudson.remoting.Channel.call(Channel.java:905)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26519:17:22 Caused: java.io.IOException: Remote call on JNLP4-connect connection from 10.70.25.27/10.70.25.27:64384 failed

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26619:17:22 at hudson.remoting.Channel.call(Channel.java:913)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26719:17:22 at hudson.Launcher$RemoteLauncher.kill(Launcher.java:1079)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26819:17:22 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:502)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,26919:17:22 at hudson.model.Run.execute(Run.java:1737)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,27019:17:22 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,27119:17:22 at hudson.model.ResourceController.execute(ResourceController.java:97)

      http://10.127.90.31:8080/view/test_view/job/android-local-test/61/console#L1,27219:17:22 at hudson.model.Executor.run(Executor.java:421)

      Attachments

        Issue Links

          Activity

            oleg_nenashev Oleg Nenashev added a comment -

            Please provide logs from the agent side

            oleg_nenashev Oleg Nenashev added a comment - Please provide logs from the agent side
            yubin89 yubin kim added a comment - - edited

            Hi, I uploaded the Jenkins master server's log as jenkins.log_tosend.

            Thanks in advance.

            yubin89 yubin kim added a comment - - edited Hi, I uploaded the Jenkins master server's log as  jenkins.log_tosend . Thanks in advance.
            oleg_nenashev Oleg Nenashev added a comment -

            I need the agent log, not the master one

            oleg_nenashev Oleg Nenashev added a comment - I need the agent log, not the master one
            yubin89 yubin kim added a comment -

            Hi, oleg_nenashev .

            Sorry for the late response.

            I uploaded org.jenkins-ci.slave.jnlp.log from the slave agent. (org.jenkins-ci.slave.jnlp.log)

             

            Thanks!

            yubin89 yubin kim added a comment - Hi, oleg_nenashev . Sorry for the late response. I uploaded org.jenkins-ci.slave.jnlp.log from the slave agent. ( org.jenkins-ci.slave.jnlp.log )   Thanks!
            jthompson Jeff Thompson added a comment -

            This one is probably a duplicate of or related to JENKINS-26257. That one involves configuration incompatibilities relating to fingerprinting. If this one is different, I suggest looking for some other similar post-build operation from some plugin.

            jthompson Jeff Thompson added a comment - This one is probably a duplicate of or related to JENKINS-26257 . That one involves configuration incompatibilities relating to fingerprinting. If this one is different, I suggest looking for some other similar post-build operation from some plugin.
            jthompson Jeff Thompson added a comment -

            Closing for lack of response providing sufficient reproduction or diagnostic information.

            jthompson Jeff Thompson added a comment - Closing for lack of response providing sufficient reproduction or diagnostic information.

            People

              Unassigned Unassigned
              yubin89 yubin kim
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: