Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49633

Filenames are no longer shown under Summary of Changes - View Detail

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: p4-plugin
    • Labels:
    • Environment:
      Jenkins 2.89.4
      p4-plugin 1.8.5
    • Similar Issues:

      Description

      After the upgrade to p4-plugin 1.8.5 we are no longer seeing "Submitted files" listed when following the link "Summary Of Changes - View Detail"

      This only seems to affect new builds.
      Builds from before the upgrade are still showing "Submitted files" correctly.

      It seems like it could be caused by the fix for JENKINS-48845 or JENKINS-47602

        Attachments

          Activity

          p4paul Paul Allen added a comment -

          Hi Andrew,

          Please can you confirm the value set for 'Maximum number of files shown in a changelist' under:

             Jenkins -> Manage Jenkins -> Configure System -> Perforce: Query limits

          The recent change in 1.8.5 will not show any files if 0 is specified.  Possibly a bug as 0 is normally used for no limit. Try setting the value to 50 and see if your files return on subsequent builds.

           

          barnish Andrew Barnish added a comment -

          Hi Paul,

          I had assumed that 0 meant infinite as it was set to 0 in previous versions of the plugin.
          You are correct that it is working if I set it to something non-zero.
          Probably the default  global configuration after p4-plugin 1.8.5 should be non-zero.

          Where are the changes stored?
          I thought that the changes were fetched dynamically from the Perforce server when the browser requests the "recent changes" link, but I'm seeing different results for each build so I'm no longer sure about that.

          Thanks

          barnish Andrew Barnish added a comment -

          I have also noticed that when the global config "Maximum number of changes shown in a build" is 0 then changes are still being displayed for each build.

          There seems to be some inconsistency or bug.

          p4paul Paul Allen added a comment -

          Hi Andrew,

          The very early version of the plugin tried to dynamically read the change and file data from Perforce, but this was full of problems; it was slow and often the connection details would be out of scope.  For the last 3 years or so the changes and files for each change are stored in jobs/JOBNAME/builds/NNN/changelog.xml, however there are links to Swarm if you use it as your Review tool/browser.

          If "Maximum number of changes shown in a build" is 0 or negative, then it is set to DEFAULT_CHANGE_LIMIT.

          DEFAULT_FILE_LIMIT = 50

          DEFAULT_CHANGE_LIMIT = 20

          The Global Configuration uses the same defaults, but only works for new Jenkins installs.  I don't reset the defaults if a user has previously set a value.

          p4paul Paul Allen added a comment -

          I will clean the code up and use the default values if either limit is set to 0?  I don't want to allow unlimited requests, but users can always set the limit to 1,000,000 if they feel the need.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Paul Allen
          Path:
          src/main/java/org/jenkinsci/plugins/p4/changes/P4ChangeEntry.java
          src/main/resources/org/jenkinsci/plugins/p4/PerforceScm/global.jelly
          http://jenkins-ci.org/commit/p4-plugin/549aa7f2d0fed4d999b2adacec9eae907fc99e98
          Log:
          Use DEFAULT_FILE_LIMIT if max file limit is set to 0.

          JENKINS-49633

          p4paul Paul Allen added a comment -

          Ready for release.

          p4paul Paul Allen added a comment -

          Released in 1.8.6


            People

            Assignee:
            p4paul Paul Allen
            Reporter:
            barnish Andrew Barnish
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: