Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4992

CI-Game does not work after updating hudson ver. 1.336

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: ci-game-plugin
    • Labels:
      None
    • Environment:
      OS: Linux
      JDK: 1.6
      Hudson ver. 1.336
      CI-game: 1.15
    • Similar Issues:

      Description

      After updating hudson to ver. 1.336 I met an exception thrown by this component. The exception is shown as below.
      SEVERE: Executor throw an exception unexpectedly
      java.lang.NoClassDefFoundError: hudson/plugins/tasks/util/model/Priority
      at hudson.plugins.cigame.rules.plugins.opentasks.OpenTasksRuleSet.loadRules(OpenTasksRuleSet.java:14)
      at hudson.plugins.cigame.rules.plugins.PluginRuleSet.getRules(PluginRuleSet.java:48)
      at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:33)
      at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:54)
      at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:56)
      at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:42)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:577)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:563)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:551)
      at hudson.model.Build$RunnerImpl.cleanUp(Build.java:158)
      at hudson.model.Run.run(Run.java:1218)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:123)

        Attachments

          Issue Links

            Activity

            mhenoch mhenoch added a comment -

            I believe this is actually caused by changes to the Open Tasks plugin (and many others). The attached patch should fix the issue; I can't try it out at the moment. Searching for 'Priority' in the rule plugins should show many other places where the corresponding change needs to be made.

            olamy Olivier Lamy added a comment -

            duplicate with JENKINS-5022.


              People

              Assignee:
              olamy Olivier Lamy
              Reporter:
              xiaoma_mt@hotmail.com xiaoma_mt@hotmail.com
              Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: