Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51111

Navigating to downstream job via Blue Ocean Triggered Builds does not show tests in Tests tab

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: blueocean-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.117
      Blue Ocean 1.5
    • Similar Issues:
    • Released As:
      1.14.0

      Description

      Steps to reproduce using two jobs:

      • First job: triggers the second job (wait = true)
      • Second job: record unit tests
      • Open Blue Ocean from the first job, click Triggered Builds to access the second job
      • The Tests tab will say no results are recorded
      • Exit Blue Ocean, and access it again from the second job
      • The Tests tab will show results

      I noticed this happening both while the job was running and complete.

        Attachments

        1. 01_Job1.png
          01_Job1.png
          74 kB
        2. 02_Job2.png
          02_Job2.png
          31 kB
        3. 03_Job2_Tests_Via_Job1.png
          03_Job2_Tests_Via_Job1.png
          32 kB
        4. 04_Job2_Direct.png
          04_Job2_Direct.png
          23 kB
        5. 05_Job2_Tests.png
          05_Job2_Tests.png
          26 kB
        6. 06_Job2_Tests.png
          06_Job2_Tests.png
          33 kB
        7. screenshot-bug.png
          screenshot-bug.png
          28 kB
        8. screenshot-okay.png
          screenshot-okay.png
          42 kB

          Issue Links

            Activity

            vivek Vivek Pandey added a comment -
            sophistifunk Josh McDonald added a comment -

            I can't replicate this, it works fine for me. Can anybody verify it?

            sophistifunk Josh McDonald added a comment -

            I will go back to 1.5 and see if I can trigger it.

            sophistifunk Josh McDonald added a comment -

            Can't replicate in 1.5 either

            woolzer Roger Wooley added a comment -

            It only happens for the most recently ran job. If I perform the same steps on an older job it I can see the tests.

             

            uriaflalo Uri Aflalo added a comment -

            Same issue is happenning to me on Blue Ocean 1.5.0.
            when navigating from Blue Ocean to a triggered test job, Tests tab says "no tests archvived".

            but when going straight to the test job, I can see the tests result.

            reinholdfuereder Reinhold Füreder added a comment - - edited

            As mentioned in the comments these two issues (this issue and JENKINS-51110) sound very much related to each other.

            reinholdfuereder Reinhold Füreder added a comment - - edited

            I also stumbled over (something like) this for "Tests" as well as for "Changes" tab (using the Firefox browser normally – although not sure if that has any relevance though):

            • And it seems to be related to opening the latest/newest Blue Ocean pipeline execution in a new browser tab from the pipeline's activity view (that lists all pipeline executions)

            Typical occurrence example:

            • A pipeline execution was triggered by SVN post commit hook, but in "Changes" tab Blue Ocean claims "there are no changes", e.g.:
            • But obiously there must have been changes (cf. SVN post commit hook)
            • => I then press <ESC> to go to the pipeline's activity view (that is listing all pipeline executions) and re-enter the same pipeline execution (still in the same browser tab!), then it shows the changes, e.g.:
            woolzer Roger Wooley added a comment -

            I updated to Blue Ocean (1.7.2) and the issue doesn't occur anymore. I'm not sure if 1.6 or 1.7.x fixed it.

            reinholdfuereder Reinhold Füreder added a comment -

            I just re-tested based on my aforementioned reproducer comment (https://issues.jenkins-ci.org/browse/JENKINS-51111?focusedCommentId=343321&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-343321) and the problem is still there for me in Blue Ocean 1.7.2! (Please mind that Jenkins core and plugin updates from last 3 weeks are yet missing, thus still using Jenkins 2.136; not sure if this is relevant at all.)

            Roger Wooley Can you try this as well? (I hope the steps to reproduce are understandable)

            reinholdfuereder Reinhold Füreder added a comment -

            I claim JENKINS-55497 solved this issue

            reinholdfuereder Reinhold Füreder added a comment -

            (I hope nobody minds my/this "Resolve")

            stuartrowe Stuart Rowe added a comment -

            I don't believe my change would have fixed this issue. It sounds like a similar bug though (retrieving and caching the run summary for the last run of a project leads to false cache hit when retrieving the full details for the same run). This code snippet looks suspicious:

            https://github.com/jenkinsci/blueocean-plugin/blob/3f049df3d253727d021e95ee53a4d1be228bf8cf/blueocean-rest-impl/src/main/java/io/jenkins/blueocean/service/embedded/rest/AbstractPipelineImpl.java#L106

            Gavin Mogan could you take a look / comment on this?

            halkeye Gavin Mogan added a comment -

            Stuart Rowe I'm confused by your comment. Sounds like you suspect its not fixed, but Reinhold Füreder says it is actually fixed for them?

            I agree, the null looks suspicious, but the PR it was merged in with (https://github.com/jenkinsci/blueocean-plugin/commit/1e05a5cf487cdb85112cbbb61d6ebf1f9cb889b4) says it was done for performance issues.

            I think a longer term better fix is making the tests page pull the data it needs if its not available, but i'm way less familiar with the actual frontend code here.

             

            stuartrowe Stuart Rowe added a comment - - edited

            I'm just saying that if it is fixed, it's not due to my PR. I looped you in in case there were any other recent BO changes that came to mind. I don't have jobs that produce xUnit style output so I haven't noticed this issue and can't confirm a fix.

            halkeye Gavin Mogan added a comment -

            Okay cool, I agree, i don't think its related to your change, but its a complicated system so who knows.

            I'm leaving this as resolved! 

            reinholdfuereder Reinhold Füreder added a comment -

            Stuart Rowe and Gavin Mogan: Sorry for the confusion. I am really extremely pretty sure that the problem I described in https://issues.jenkins-ci.org/browse/JENKINS-51111?focusedCommentId=343321&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-343321 (with rather straightforward reproducer steps) works now as expected (for "changes" AND for "tests") – and I think that was really the same problem as this issue's original description.

            However, I could also imagine that Stuart Rowe is perfectly right about that he only fixed the "changes" now in the course of JENKINS-55497, and "tests" was already fixed some time ago...


              People

              Assignee:
              sophistifunk Josh McDonald
              Reporter:
              woolzer Roger Wooley
              Votes:
              2 Vote for this issue
              Watchers:
              9 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: