Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5993

"Archive the artifacts" does not honor symbolic links

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Hudson ver. 1.351
    • Similar Issues:

      Description

      Our build steps produce artifacts with symbolic links.
      If "Archive the artifacts" is used then it creates full (deep) copies of the files the symbolic links point to in the archive instead of copying (and therefore preserving) the symbolic links.

        Attachments

          Issue Links

            Activity

            abayer Andrew Bayer added a comment -

            This is a duplicate of JENKINS-5597, and is a feature request, not a bug.

            lothar_werzinger lothar_werzinger added a comment -

            In my environment I need the symbolic links, not copies of the files so for me this is not an enhancement, as "Archive the artifacts" is unusable for me. I still consider it to be a bug.


              People

              Assignee:
              gbois Gregory Boissinot
              Reporter:
              lothar_werzinger lothar_werzinger
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: