Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60229

Jenkins unable to get updates / update details of Allure Jenkins plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: allure-plugin, core
    • Environment:
    • Similar Issues:

      Description

      Upon updating to Jenkins 2.205, our Jenkins setup became unable to get plugin updates.
      I see the following error now:

      "There were errors checking the update sites: None of the tool installer metadata passed the signature check"

      update from Thomas Patzig
      happens again with Jenkins 2.289.2

      response / JSON of update URL looks invalid

      does the update service works properly?
      https://updates.jenkins.io/update-center.json
      http://updates.jenkins.io/update-center.json
      http://updates.jenkins.io/current/update-center.json

        Attachments

          Issue Links

            Activity

            duemir Denys Digtiar added a comment -

            If timestamps are to be trusted on https://updates.jenkins.io/updates/ the ru.yandex.qatools.allure.jenkins.tools.AllureCommandlineInstaller.json* have not been updated since 2021-05-02. I do not know how signatures of these files are generated but I don't think it has anything to do with https certificates of their sites. Maybe it has something to do with the fact that Allure used to host on Bintray which is now gone. I created https://github.com/jenkins-infra/crawler/pull/107 . Not sure if it is going to resolve it or not but should fix the tool discovery (crawling) error.

            duemir Denys Digtiar added a comment -

            Thomas Patzig could you please check now? I believe this is fixed. I cannot reproduce it anymore.

            thomaspatzig Thomas Patzig added a comment -

            to Denys Digtiar

            I confirm

            issue not exists any longer from now
            I haven't changed anything on my side.

            ricardojdsilva87 Ricardo added a comment -

            Hello,
            I can also confirm that the issue is now gone after reenabling the plugin installation. Haven't change a thing in my configuration.

            I'm using Jenkins version 2.289.2-lts JDK11 version.
            Thanks

            duemir Denys Digtiar added a comment -

            I am going to resolve it as fixed again then. It looks like my theory was correct. After my PR was merge the signature of the metadata was updated.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              panajev Goffredo Marocchi
              Votes:
              1 Vote for this issue
              Watchers:
              15 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: