Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62219

Role-based Authorization Strategy can't be effect immediately when assigned a none admin role to a new User

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Fixed
    • role-strategy-plugin
    • None
    • Jenkins 2.204.5
      official docker image Jenkins-blueocean
      AWS Linux base centos
      Role-based Authorization Strategy 2.16
    • Role Strategy 3.1

    Description

      Hi guys,

      I've use offical docker image to run a jenkins container

      When I create a new user and assign it to a none-admin role ( only have read all and read jobs permmsions and regular expression to filter jobs),

      that account can't see any jobs at that time.

      The jobs will not show up until 20 minutes later or much longer or restart jenkins

      Attachments

        Issue Links

          Activity

            marksugar marksugar t added a comment -

            With the same configuration, this problem still exists.

            versinon:
            jenkins: 2.235.1, 2.204.5
            Role-based Authorization Strategy: 3.0, 2.16

            The only difference is that after I waited for a day, the Item roles still did not take effect.

            I don't know what happened in the new version. . .

            marksugar marksugar t added a comment - With the same configuration, this problem still exists. versinon: jenkins: 2.235.1, 2.204.5 Role-based Authorization Strategy: 3.0, 2.16 The only difference is that after I waited for a day, the Item roles still did not take effect. I don't know what happened in the new version. . .
            oleg_nenashev Oleg Nenashev added a comment -

            The fix was released in 3.1, closing as a duplicate of JENKINS-61470 which is the earlier report

            oleg_nenashev Oleg Nenashev added a comment - The fix was released in 3.1, closing as a duplicate of  JENKINS-61470  which is the earlier report

            People

              oleg_nenashev Oleg Nenashev
              bishop jianfeng ru
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: