Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62302

Jenkins slowing down , finally read time out

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      - Docker 19.03.5 on Ubuntu 16.04
      - jenkins/jenkins:2.229-jdk11
      - reverse proxy traefik 2.2.1
      - ssh docker agents
      - master without build slot
    • Similar Issues:

      Description

      Hi there,

       

      since v2.229 we are experiencing Jenkins getting "slow" with ending up finally inaccessible: "read time out"

      First this behaviour happend all 1-2 days now it happens 1-3 times a day.

      • Host got 8 CPU Cores
      • Jenkins can get 3GB RAM max (it reaches 1,5 max)

      I also found out that if this happens one of the 8 CPU Cores runs at 100% permanentely - thats probably one Symptom for this behaviour.

       

      I also removed old crap & stuff and got some more defensiv Scanning times and so on.

      Nothing helps.

       

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            This report does not include any information that would help diagnose.

            Do this: https://wiki.jenkins.io/display/JENKINS/Obtaining+a+thread+dump

            Then report results.

            heinzepreller heinzepreller added a comment - - edited

            Hi,

            i do have a thread-Dump of this Issue now:

            threadDump.7z

             

            Maybe it has something todo with: JENKINS-52374 ?

             

            danielbeck Daniel Beck added a comment -

            heinzepreller Seems reasonable. Do you use LDAP Plugin or Active Directory Plugin (or something else entirely) for the security realm?

            heinzepreller heinzepreller added a comment - - edited

            yes, we are also using 

            • active-directory-plugin 2.8
            • MS Active Directory
            • STARTTLS enabled

             

             

            danielbeck Daniel Beck added a comment -

            This looks a lot like a duplicate of JENKINS-52374, you're right.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              heinzepreller heinzepreller
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: