Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63990

Declarative Pipeline: remove explicit com.fasterxml.jackson.datatype:jackson-datatype-json-org dependency in newer version

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Jackson 2 API plugin offers com.fasterxml.jackson.datatype:jackson-datatype-json-org starting from https://github.com/jenkinsci/jackson2-api-plugin/releases/tag/jackson2-api-2.11.3 by Liam Newman.  Right now the upper bounds check fails when using the versions supplied by BOMs

       

      Require upper bound dependencies error for com.fasterxml.jackson.datatype:jackson-datatype-json-org:2.9.8 paths to dependency are:

      +-io.jenkins.jenkinsfile-runner:payload-dependencies:1.0-beta-19-SNAPSHOT

          +org.jenkinsci.plugins:pipeline-model-definition:1.7.2 (managed) <- org.jenkinsci.plugins:pipeline-model-definition:1.7.1

            +-org.jenkinsci.plugins:pipeline-model-api:1.7.2

              +-com.fasterxml.jackson.datatype:jackson-datatype-json-org:2.9.8

      and

      +-io.jenkins.jenkinsfile-runner:payload-dependencies:1.0-beta-19-SNAPSHOT

          +org.jenkinsci.plugins:pipeline-model-definition:1.7.2 (managed) <- org.jenkinsci.plugins:pipeline-model-definition:1.7.1

            +-org.jenkinsci.plugins:pipeline-model-api:1.7.2

              +org.jenkins-ci.plugins:jackson2-api:2.11.3 (managed) <- org.jenkins-ci.plugins:jackson2-api:2.9.8

                +-com.fasterxml.jackson.datatype:jackson-datatype-json-org:2.11.3

       

       

       

       

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            oleg_nenashev Oleg Nenashev
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: