Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64361

ERROR: Error fetching remote repo 'origin'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: git-client-plugin
    • Labels:
      None
    • Environment:
      Jenkins <version>2.263.1</version>
      Remote Agent at z/OS USS
    • Similar Issues:

      Description

      Started by user abc Started by user abc Running as SYSTEMBuilding remotely on zOS-Agent (xyz1234) in workspace /u/rabc/Jenkins-PC/workspace/pocPipelineThe recommended git tool is: NONEusing credential rabcprivatekey > /var/gitzos/bin/git rev-parse --is-inside-work-tree # timeout=10Fetching changes from the remote Git repository > /var/gitzos/bin/git config remote.origin.url git@github.com:abcabcgit/poc-workspace.git # timeout=10Fetching upstream changes from git@github.com:abcabcgit/poc-workspace.git > /var/gitzos/bin/git --version # timeout=10 > git --version # 'git version 2.14.4_zos_b09'using GIT_SSH to set credentials Private Key from USS /u/user/.ssh for JenkinsUsing passphrase charset 'IBM1047' > /var/gitzos/bin/git fetch --tags --progress – git@github.com:abcabcgit/poc-workspace.git +refs/heads/:refs/remotes/origin/ # timeout=10E*RROR: Error fetching remote repo 'origin'hudson.plugins.git.GitException: Failed to fetch from git@github.com:abcabcgit/poc-workspace.git at hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:996) at hudson.plugins.git.GitSCM.retrieveChanges(GitSCM.java:1237) at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1297) at hudson.scm.SCM.checkout(SCM.java:505) at hudson.model.AbstractProject.checkout(AbstractProject.java:1206) at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:637) at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:509) at hudson.model.Run.execute(Run.java:1907) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:97) at hudson.model.Executor.run(Executor.java:429)Caused by: hudson.plugins.git.GitException: Command "/var/gitzos/bin/git fetch --tags --progress – git@github.com:abcabcgit/poc-workspace.git +refs/heads/:refs/remotes/origin/*" returned status code 128:stdout: FOTS1336 ssh: Could not resolve hostname github.com: EDC9501I The name does not resolve for the supplied parameters.fatal: Could not read from remote repository.
      Please make sure you have the correct access rightsand the repository exists.
      stderr:  at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:2450) at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:2051) at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.access$500(CliGitAPIImpl.java:84) at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$1.execute(CliGitAPIImpl.java:573) at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$GitCommandMasterToSlaveCallable.call(RemoteGitImpl.java:161) at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$GitCommandMasterToSlaveCallable.call(RemoteGitImpl.java:154) at hudson.remoting.UserRequest.perform(UserRequest.java:211) at hudson.remoting.UserRequest.perform(UserRequest.java:54) at hudson.remoting.Request$2.run(Request.java:375) at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:73) at java.util.concurrent.FutureTask.run(FutureTask.java:277) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1160) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635) at java.lang.Thread.run(Thread.java:820) Suppressed: hudson.remoting.Channel$CallSiteStackTrace: Remote call to zOS-Agent at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1800) at hudson.remoting.UserRequest$ExceptionResponse.retrieve(UserRequest.java:357) at hudson.remoting.Channel.call(Channel.java:1001) at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler.execute(RemoteGitImpl.java:146) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler.invoke(RemoteGitImpl.java:132) at com.sun.proxy.$Proxy67.execute(Unknown Source) at hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:994) at hudson.plugins.git.GitSCM.retrieveChanges(GitSCM.java:1237) at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1297) at hudson.scm.SCM.checkout(SCM.java:505) at hudson.model.AbstractProject.checkout(AbstractProject.java:1206) at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:637) at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:509) at hudson.model.Run.execute(Run.java:1907) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:97) at hudson.model.Executor.run(Executor.java:429)ERROR: Error fetching remote repo 'origin'Finished: FAILURE

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          A stack trace with no further explanation is not a bug report that I will generally attempt to address. Please refer to "How to report an issue" for the type of information that is needed in a bug report.

          Bug reports to an open source project are an attempt to persuade someone to help you with their personal time. When the bug report is difficult to read, unclear, or incomplete, it reduces the likelihood that the maintainer will provide help. Bug reports on platforms that are not accessible to the maintainer (like z/OS USS) are even less likely to receive help, since it is much more difficult for the maintainer to duplicate the problem.

          In this case, the stack trace status that the ssh command could not resolve the hostname 'github.com'. The agent operating system needs to be configured so that it can resolve the hostname 'github.com'.


            People

            Assignee:
            markewaite Mark Waite
            Reporter:
            raylamjenkins Ray Lam
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: