Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64804

After updating "GitHub Branch Source" version to github-branch-source:2.10.0, our jenkins is not loading, jenkins version updated to jenkins:2.263.3-lts

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After git plugin update and also jenkins image version changed to jenkins:2.263.3-lts. Jenkins instance is not coming up.

      Reverted the github-branch-source:2.9.3, now jenkins works fine.

      I should update to 2.9.4, since 2.10.0 is not working with the latest 2.263.3-lts jenkins

       Below is the Jenkins error

      io.jenkins.plugins.casc.ConfiguratorException: Invalid configuration elements for type class jenkins.model.GlobalConfigurationCategory$Unclassified : gitHubConfiguration.
      Available attributes : administrativeMonitorsConfiguration, ansiColorBuildWrapper, ansibleTowerGlobalConfig, artifactManager, buildDiscarders, casCGlobalConfig, codeBuilder, configuration, defaultFolderConfiguration, defaultView, envInjectNodeProperty, envVarsFilter, fingerprints, gitHubPluginConfig, gitSCM, globalConfigFiles, globalDefaultFlowDurabilityLevel, globalLibraries, groovy, junitTestResultStorage, location, lockableResourcesManager, mailer, maskPasswordsBuildWrapper, masterBuild, mavenModuleSet, myView, nodeProperties, phaseJobsConfig, pipeline-model-docker, plugin, pluginImpl, pollSCM, projectNamingStrategy, quietPeriod, rebuildDescriptor, resourceRoot, scmRetryCount, shell, singleConditionalBuilder, sparkNotifyBuilder, sparkNotifyPostBuilder, sparkSendStep, throttleJobProperty, timestamper, upstream, usageStatistics, veracodeNotifier, viewsTabBar, warningsParsers, warningsPlugin, whitelist
      	at io.jenkins.plugins.casc.BaseConfigurator.handleUnknown(BaseConfigurator.java:376)
      	at io.jenkins.plugins.casc.BaseConfigurator.configure(BaseConfigurator.java:365)
      	at io.jenkins.plugins.casc.BaseConfigurator.check(BaseConfigurator.java:287)
      	at io.jenkins.plugins.casc.ConfigurationAsCode.lambda$checkWith$8(ConfigurationAsCode.java:755)
      	at io.jenkins.plugins.casc.ConfigurationAsCode.invokeWith(ConfigurationAsCode.java:691)
      Caused: io.jenkins.plugins.casc.ConfiguratorException: unclassified: error configuring 'unclassified' with class io.jenkins.plugins.casc.impl.configurators.GlobalConfigurationCategoryConfigurator configurator
      	at io.jenkins.plugins.casc.ConfigurationAsCode.invokeWith(ConfigurationAsCode.java:697)
      	at io.jenkins.plugins.casc.ConfigurationAsCode.checkWith(ConfigurationAsCode.java:755)
      	at io.jenkins.plugins.casc.ConfigurationAsCode.configureWith(ConfigurationAsCode.java:740)
      	at io.jenkins.plugins.casc.ConfigurationAsCode.configureWith(ConfigurationAsCode.java:616)
      	at io.jenkins.plugins.casc.ConfigurationAsCode.configure(ConfigurationAsCode.java:298)
      	at io.jenkins.plugins.casc.ConfigurationAsCode.init(ConfigurationAsCode.java:290)
      Caused: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:104)
      Caused: java.lang.Error
      	at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110)
      	at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
      	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1131)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at jenkins.security.ImpersonatingExecutorService$1.run(ImpersonatingExecutorService.java:59)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
      	at java.lang.Thread.run(Thread.java:748)
      Caused: org.jvnet.hudson.reactor.ReactorException
      	at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:282)
      	at jenkins.InitReactorRunner.run(InitReactorRunner.java:50)
      	at jenkins.model.Jenkins.executeReactor(Jenkins.java:1164)
      	at jenkins.model.Jenkins.<init>(Jenkins.java:964)
      	at hudson.model.Hudson.<init>(Hudson.java:85)
      	at hudson.model.Hudson.<init>(Hudson.java:81)
      	at hudson.WebAppMain$3.run(WebAppMain.java:295)
      Caused: hudson.util.HudsonFailedToLoad
      	at hudson.WebAppMain$3.run(WebAppMain.java:312)
      

        Attachments

          Activity

          Hide
          abdennour Abdennour Toumi added a comment -

          I am between Between the hammer and the anvil (المطرقة و السندان) :

          • jenkins 2.263 lts + blueocean 1.32.2 ==> git-branch-source-plugin 2.10.1 not compatible with jenkins lts
          • jenkins 2.263 lts + git-branch-source-plugin 2.94 ==> Plugin blueocean:1.23.2 depends on github-branch-source:2.10.1

           

          Show
          abdennour Abdennour Toumi added a comment - I am between Between the hammer and the anvil (المطرقة و السندان) : jenkins 2.263 lts + blueocean 1.32.2 ==> git-branch-source-plugin 2.10.1 not compatible with jenkins lts jenkins 2.263 lts + git-branch-source-plugin 2.94 ==> Plugin blueocean:1.23.2 depends on github-branch-source:2.10.1  

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            hashim Hashim
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: