Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67420

bitbucket-hook not triggering build job - trigger not set

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Blocker
    • Resolution: Unresolved
    • None
    • jenkins version: 2.277.4
      bitbucket push and pull request plugin version: 1.5
      OS: linux running on AWS ec2 instance
      running bitbucket cloud

    Description

      I am attempting to setup the  Bitbucket push and pull request plugin to run pipeline jobs when PR's are created, for any branch of a given repo.  

      I followed the configuration steps provided. but I am receiving a 500 status response in my webbook. The jenkins server is receiving the request but in my Jenkins server logs, the output is saying that "Trigger is not set". However I created several triggers for PR created, updated,  approved, merged, as well as a trigger for push. 

      In addition I  uninstalled Bitbucket plugin and restarted the Jenkins server, prior to installing this plugin as well. 

      I cant seem to get this to work. Any assistance will be greatly appreciated. 

       

      Attached are screenshots of

      1. my pipeline job configuration, 

      2. My jenkinsfile

      3. my webhook setup 

      4. my webhook response

      4. my logfile.

       

      Attachments

        1. webhook-response.png
          webhook-response.png
          49 kB
        2. webhook-config.png
          webhook-config.png
          50 kB
        3. log-file2.png
          log-file2.png
          123 kB
        4. log-file1.png
          log-file1.png
          153 kB
        5. job-configuration-3.jpg
          job-configuration-3.jpg
          292 kB
        6. job-configuration-2.png
          job-configuration-2.png
          52 kB
        7. job-configuration-1.png
          job-configuration-1.png
          59 kB
        8. Jenkinsfile-1
          2 kB

        Activity

          I do have the same "Trigger not set" in my logs, running plugin version 2.8.1 on Jenkins 2.233.1, with similar setup.

          xjom Mattias Vannergård added a comment - I do have the same "Trigger not set" in my logs, running plugin version 2.8.1 on Jenkins 2.233.1, with similar setup.

          People

            cdelmonte Christian Del Monte
            ayalgul ayal gul
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated: