Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19374

issue with HP Application Automation Tools plugin - error: Could not create scheduler, please verify ALM client installation on run machine by downloading and in installing the add-in form: http://Almserver:Portnumber/qcbin/TDConnectivity_index.html

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hi All,
      we are facing the attached error when tried to execute the hp test scripts under hp ALM(Version11.0) from jenkins(Version1.476) using HP Application Automation Tools plugin(current Version). Referring solution from JENKINS-16464 issue(https://issues.jenkins-ci.org/browse/JENKINS-16464) I had also tried after downloading content from url(http://AlmServer:8080/qcbin/start_a.jsp?common=true) but same error repeated.

      Thanks in advance,
      any help is very much appreciated and
      please comment if any further info is needed on the issue,

      Update: Error is also occurring in our environment on ALM 11.52 since patch 4 was installed. It was working fine before installing patch 4. We have tested on Jenkins version 1.517 and version 1.581 with the HP Application Automation Tools plugin version 3.0.5.
      Additional information: The Event Viewer on the Jenkins server reports an application error with "wexectrl.exe", version 11.52.536.0. Please see attachment for further detail.

        Attachments

        1. cleanAlmClient.bat
          6 kB
          Amit Bezalel
        2. error.JPG
          54 kB
          Alisha Gakhar
        3. event viewer error.png
          59 kB
          Marlene Macdonald
        4. issue.png
          27 kB
          Vamsi Hari
        5. scheduler issue.7z
          67 kB
          xiwen zhao
        6. step1.png
          50 kB
          xiwen zhao
        7. step2.png
          16 kB
          xiwen zhao
        8. step3.png
          25 kB
          xiwen zhao
        9. step4.png
          57 kB
          xiwen zhao
        10. step5done.png
          13 kB
          xiwen zhao

          Activity

          Hide
          xiwenhpe xiwen zhao added a comment -

          Hi,

          We are not able to reproduce the problem locally, there is not much we can do at this stage.

          If you need to solve this issue please contact UFT support or ALM support to open a ticket, professional support team will follow up this issue. In this way your problem will have monitoring and tracking, in addition the case will be raised to higher level if it can not be solved in a short time. In another word it is guaranteed to be fixed by raising a support ticket.

          Meanwhile I will mark this issue as closed.

          Show
          xiwenhpe xiwen zhao added a comment - Hi, We are not able to reproduce the problem locally, there is not much we can do at this stage. If you need to solve this issue please contact UFT support or ALM support to open a ticket, professional support team will follow up this issue. In this way your problem will have monitoring and tracking, in addition the case will be raised to higher level if it can not be solved in a short time. In another word it is guaranteed to be fixed by raising a support ticket. Meanwhile I will mark this issue as closed.
          Hide
          xiwenhpe xiwen zhao added a comment -

          resolved, suggest customers to open UFT support ticket or ALM support ticket.

          Show
          xiwenhpe xiwen zhao added a comment - resolved, suggest customers to open UFT support ticket or ALM support ticket.
          Hide
          evanchen Evan Chen added a comment -

          Have anyone tried to run the test on the exact slave machine via ALM client on the machine directly? Wondering if there's something wrong with the ALM client.

          Show
          evanchen Evan Chen added a comment - Have anyone tried to run the test on the exact slave machine via ALM client on the machine directly? Wondering if there's something wrong with the ALM client.
          Hide
          karan_raka2003 Kiran Raka added a comment -

          I tried and it works if you run from HP ALM on the host machine but on otherhand if its Jenkin job fails with same error as above

          I am able to reproduce this issue everyday

          Show
          karan_raka2003 Kiran Raka added a comment - I tried and it works if you run from HP ALM on the host machine but on otherhand if its Jenkin job fails with same error as above I am able to reproduce this issue everyday
          Hide
          xiwenhpe xiwen zhao added a comment -
          1. You said it worked when you ran from host machine, so it only fails when you try to run on slave machine right?
          2. i dont quite understand the second part, what job fails? running from where(master or slave)? did you try to restart jenkins server? did you try to restart slave machine or terminate ALM related processes manually? Possibly ALM client process was not terminated correctly so it failed to create scheduler.

           

          Show
          xiwenhpe xiwen zhao added a comment - You said it worked when you ran from host machine, so it only fails when you try to run on slave machine right? i dont quite understand the second part, what job fails? running from where(master or slave)? did you try to restart jenkins server? did you try to restart slave machine or terminate ALM related processes manually? Possibly ALM client process was not terminated correctly so it failed to create scheduler.  

            People

            Assignee:
            xiwenhpe xiwen zhao
            Reporter:
            hvamsik Vamsi Hari
            Votes:
            5 Vote for this issue
            Watchers:
            12 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: