Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-291

a record needed why a build has started (what triggered it)

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • core
    • None
    • Platform: PC, OS: Linux

    Description

      It would be good to know what a build triggered. When a user triggered it via
      the web-site I would like to know who it was (that requires authentication).
      Other build reasons: a succeeded build of another project, a wget request by a
      script, a cron trigger.

      Attachments

        1. patch.291
          15 kB
        2. patch.291.feb5
          19 kB
        3. patch.291.feb8
          20 kB
        4. patch.issue291.4feb
          17 kB

        Issue Links

          Activity

            mdonohue mdonohue added a comment -

            > it would be much nicer if it displayed upstream builds as a link
            > to that particular build rather than just a textual description.

            This would best be handled by a new enhancement request, or becoming a
            contributor yourself.

            mdonohue mdonohue added a comment - > it would be much nicer if it displayed upstream builds as a link > to that particular build rather than just a textual description. This would best be handled by a new enhancement request, or becoming a contributor yourself.
            ejono ejono added a comment -

            Yeah, I guess so. Maybe once I graduate I'll become a contributor.

            ejono ejono added a comment - Yeah, I guess so. Maybe once I graduate I'll become a contributor.
            mindless Alan Harder added a comment -

            that request is issue #3054

            mindless Alan Harder added a comment - that request is issue #3054
            mdonohue mdonohue added a comment -
                • Issue 2123 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment - Issue 2123 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment -
                • Issue 2522 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment - Issue 2522 has been marked as a duplicate of this issue. ***

            People

              mdonohue mdonohue
              gradopado gradopado
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: