Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42547

io.jenkins.blueocean.dashboard.harmonizeTimes errors in browser console

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: blueocean-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.48, BlueOcean plugin 1.0.0-b25, Firefox 51
    • Similar Issues:
    • Sprint:
      1.0, Blue Ocean 1.0-rc3, Blue Ocean 1.0-rc4

      Description

      When trying to go through input steps I'm getting similar problems as with JENKINS-41662.

      But now I see an error in console:

      [ERROR - io.jenkins.blueocean.dashboard.harmonizeTimes] not found any startTime, seems that a component should not have called this me blueocean.js:17774:9
      
      [127]</Logger.prototype.error http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:17774:9
          harmonizeTimes http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:7805:17
          convertJenkinsNodeDetails http://10.111.161.234/adjuncts/03cf73dc/org/jenkins/ui/jsmodules/blueocean-dashboard/jenkins-js-extension.js:49368:33
          convertJenkinsNodeGraph/< http://10.111.161.234/adjuncts/03cf73dc/org/jenkins/ui/jsmodules/blueocean-dashboard/jenkins-js-extension.js:49439:29
          convertJenkinsNodeGraph http://10.111.161.234/adjuncts/03cf73dc/org/jenkins/ui/jsmodules/blueocean-dashboard/jenkins-js-extension.js:49438:5
          processData http://10.111.161.234/adjuncts/03cf73dc/org/jenkins/ui/jsmodules/blueocean-dashboard/jenkins-js-extension.js:49514:34
          componentWillMount http://10.111.161.234/adjuncts/03cf73dc/org/jenkins/ui/jsmodules/blueocean-dashboard/jenkins-js-extension.js:49499:13
          [512]</ReactCompositeComponentMixin.performInitialMount http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:83396:9
          [512]</ReactCompositeComponentMixin.mountComponent http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:83303:16
          [563]</ReactReconciler.mountComponent http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:90316:18
          [512]</ReactCompositeComponentMixin.performInitialMount http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:83416:18
          [512]</ReactCompositeComponentMixin.mountComponent http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:83303:16
          [563]</ReactReconciler.mountComponent http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:90316:18
          [512]</ReactCompositeComponentMixin.performInitialMount http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:83416:18
          [512]</ReactCompositeComponentMixin.mountComponent http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:83303:16
          [563]</ReactReconciler.mountComponent http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:90316:18
          mountComponentIntoNode http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:88535:16
          [589]</Mixin.perform http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:93514:13
          batchedMountComponentIntoNode http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:88557:3
          [534]</ReactDefaultBatchingStrategy.batchedUpdates http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:87195:7
          batchedUpdates http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:91413:3
          [551]</ReactMount._renderNewRootComponent http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:88751:5
          [551]</ReactMount._renderSubtreeIntoContainer http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:88832:21
          [551]</ReactMount.render http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:88853:12
          _renderExtension http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:15518:17
          _renderAllExtensions http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:15500:25
          componentDidMount http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:15392:13
          [479]</<.notifyAll http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:78088:9
          [562]</ON_DOM_READY_QUEUEING.close http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:90182:5
          [589]</Mixin.closeAll http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:93580:11
          [589]</Mixin.perform http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:93527:11
          [589]</Mixin.perform http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:93514:13
          [571]</<.perform http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:91405:12
          [571]</flushBatchedUpdates http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:91488:7
          [589]</Mixin.closeAll http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:93580:11
          [589]</Mixin.perform http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:93527:11
          [534]</ReactDefaultBatchingStrategy.batchedUpdates http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:87197:7
          enqueueUpdate http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:91516:5
          enqueueUpdate http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:91124:3
          [570]</ReactUpdateQueue.enqueueSetState http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:91309:5
          [508]</ReactComponent.prototype.setState http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:82615:3
          handleChange http://10.111.161.234/adjuncts/03cf73dc/org/jenkins/ui/jsmodules/react-redux/react-redux-4-4-5.js:1924:9
          dispatch http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:97684:7
          createThunkMiddleware/</</< http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:97195:16
          dispatch http://10.111.161.234/adjuncts/03cf73dc/io/jenkins/blueocean/blueocean.js:97250:18
          fetchNodes/</< http://10.111.161.234/adjuncts/03cf73dc/org/jenkins/ui/jsmodules/blueocean-dashboard/jenkins-js-extension.js:59420:21

      So it doesn't look like JENKINS-41662 is being fixed for us. Or maybe it behaves similar because of THIS error.

        Attachments

          Issue Links

            Activity

            jamesdumay James Dumay added a comment -

            Michael Neale heres one for the bug squash

            jamesdumay James Dumay added a comment - - edited

            Oleg Korsak would you be able to generate a har file in a browser session that reproduces this problem, please? For privacy, email it directly to jdumay@cloudbees.com and Ill make it available to a CloudBees developer to investigate.

            michaelneale Michael Neale added a comment -

            FYI I see these ererors too but they don't seem to be the cause of the problem necessarily (they can happen without ill effect) but this needs investigation. A har file would be nice yes. 

            michaelneale Michael Neale added a comment -

            Also Oleg Korsak could we have a sample Jenkinsfile to show this input that is causing this? 

            michaelneale Michael Neale added a comment -

            Giving this to Thor as he has some WIP on karaoke that makes this go away. 

            tscherler Thorsten Scherler added a comment -

            Michael Neale was that the one we saw "your last night"? You said this is a known issue, did you refer to "this"?

            michaelneale Michael Neale added a comment -

            This may go away with https://github.com/jenkinsci/blueocean-plugin/pull/839 - so I am parking this one now for future review while that is in progress... 

            jamesdumay James Dumay added a comment -

            Haven't seen these errors since karaoke landed


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              kamikaze Oleg Korsak
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: