Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44695

Git issued SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Not A Defect
    • None
    • Jenkins version:1.565.3, Git-client:1.21.0, Git plugin:2.2.12, RHEL and curl version 7.19.7

    Description

      I am getting SSL verify failed with curl>=7.19.4 error with Git polling. But a normal build, as well as SCM builds, are working fine in my environment. Can someone let me know what exactly the issue could be?

       

      stderr: warning: protocol restrictions not applied to curl redirects because your curl version is too old (>= 7.19.4) fatal: unable to access '

      https://github.com/phanikumar1210/ToolTest.git/

      ': SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

      Attachments

        Activity

          phani_kumar Phani Kumar added a comment -

          to my surprise, the SCM polling is working fine. The only change additional parameter is configuring the polling which marked for every minute. I assume it couldn't be a configuration issue.

          phani_kumar Phani Kumar added a comment - to my surprise, the SCM polling is working fine. The only change additional parameter is configuring the polling which marked for every minute. I assume it couldn't be a configuration issue.
          markewaite Mark Waite added a comment -

          This is likely a configuration issue on the master or on the agent where the polling is executing. It is not a bug in the plugin.

          You'll get better results if you ask the configuration related question on the jenkins users mailing list. There are more people there who can answer configuration related questions, rather than the relatively few people that read bug reports.

          markewaite Mark Waite added a comment - This is likely a configuration issue on the master or on the agent where the polling is executing. It is not a bug in the plugin. You'll get better results if you ask the configuration related question on the jenkins users mailing list. There are more people there who can answer configuration related questions, rather than the relatively few people that read bug reports.

          People

            Unassigned Unassigned
            phani_kumar Phani Kumar
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: