Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51744

No jobs are scheduled

    XMLWordPrintable

Details

    Description

      Reproduction steps on my side:

      1. new item
      2. project name "test-parameterized-scheduler"
      3. Check "This project is parameterized"
        1. name: some_string
        2. Default Value: some_value
      4. Save job
      5. Configure job again
      6. Check "Build periodically with parameters"
        1. Schedule:
          * * * * * % some_string=blah
      1. Build section
        1. Execute shell
          echo "testing"
      1. Save

      Job never fires off

      Please let me know what log files you may need. I don't think I can submit a support bundle outright, as it would contain our hostnames in our private organization.

       

      Attachments

        Activity

          shatun shatun shatun added a comment -

          We've faced with the same problem

          Jenkins ver. 2.107.3 LTS running in off docker image 

          Sometimes the scheduled job does fire, but in absolutely random time and date, for example a weekly job instead of Sun 5:32:56 AM has started on Mon 11:27:13 AM.

          It seems to be somehow connected to git plugin(s), we have added a few jobs a couple days ago, each one polls github  pull requests every 4 minutes, after disabling the polling, finally got scheduler work

          There are no any errors in logs so still playing with the settings, if there is any way to fix it without disabling polling that could be awesome

           

           

           

           

           

          shatun shatun shatun added a comment - We've faced with the same problem Jenkins ver. 2.107.3 LTS  running in off docker image  Sometimes the scheduled job does fire, but in absolutely random time and date, for example a weekly job instead of Sun 5:32:56 AM has started on Mon 11:27:13 AM. It seems to be somehow connected to git plugin(s), we have added a few jobs a couple days ago, each one polls github  pull requests every 4 minutes, after disabling the polling, finally got scheduler work There are no any errors in logs so still playing with the settings, if there is any way to fix it without disabling polling that could be awesome          

          I can't reproduce this, is there any way to reproduce this issue?

          raihaan Raihaan Shouhell added a comment - I can't reproduce this, is there any way to reproduce this issue?

          People

            batmat Baptiste Mathus
            mtdeguzis Michael DeGuzis
            Votes:
            4 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

              Created:
              Updated: