Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64378

The parameter of the job will be removed with any save aciton.

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I opened the job but without any changes, Just click the save button. The parameter of the job will be removed.

        Attachments

        1. tfs-plugin.png
          tfs-plugin.png
          7 kB
        2. 2.png
          2.png
          63 kB
        3. 1.png
          1.png
          65 kB

          Activity

          Hide
          markewaite Mark Waite added a comment -

          I've reassigned the issue to Jenkins core since it was incorrectly reported to Jenkins Infra.

          I am unable to duplicate the problem as reported by the user. Steps I took while attempting to duplicate the problem:

          1. Run a Docker image of Jenkins 2.269 with the plugins as listed in my lts-with-plugins branch (see the ref/plugins directory for the specific plugins at commit fbe3b94361f5c110addd64c2410fd65e4ce72f83
          2. Edit existing job JENKINS-27352-parameterized-branch-does-not-poll and save it with no changes
          3. Edit existing job JENKINS-27352-parameterized-branch-does-not-poll and save it after adding a boolean parameter
          4. Edit existing job JENKINS-27352-parameterized-branch-does-not-poll and save it after adding modifying a git parameter
          5. Edit existing job JENKINS-27352-parameterized-branch-does-not-poll and save it after adding a boolean parameter with inverted default value

          In all those cases of edit and save, the parameter and the job definition was correctly saved.

          Unless the submitter of the bug report provides more data to allow others to duplicate the problem, I propose we close this as "Not a defect" and "Cannot reproduce".

          Instructions for bug reporting to the Jenkins project are included in the "How to report an issue" page.

          kim info can you provide more information so that others can duplicate the problem? Are you running the most recent releases of Jenkins plugins on your installation? Are there other conditions that would make your Jenkins installation behave differently than mine?

          Show
          markewaite Mark Waite added a comment - I've reassigned the issue to Jenkins core since it was incorrectly reported to Jenkins Infra. I am unable to duplicate the problem as reported by the user. Steps I took while attempting to duplicate the problem: Run a Docker image of Jenkins 2.269 with the plugins as listed in my lts-with-plugins branch (see the ref/plugins directory for the specific plugins at commit fbe3b94361f5c110addd64c2410fd65e4ce72f83 Edit existing job JENKINS-27352-parameterized-branch-does-not-poll and save it with no changes Edit existing job JENKINS-27352-parameterized-branch-does-not-poll and save it after adding a boolean parameter Edit existing job JENKINS-27352-parameterized-branch-does-not-poll and save it after adding modifying a git parameter Edit existing job JENKINS-27352-parameterized-branch-does-not-poll and save it after adding a boolean parameter with inverted default value In all those cases of edit and save, the parameter and the job definition was correctly saved. Unless the submitter of the bug report provides more data to allow others to duplicate the problem, I propose we close this as "Not a defect" and "Cannot reproduce". Instructions for bug reporting to the Jenkins project are included in the "How to report an issue" page. kim info can you provide more information so that others can duplicate the problem? Are you running the most recent releases of Jenkins plugins on your installation? Are there other conditions that would make your Jenkins installation behave differently than mine?
          Hide
          kimxinfo kim info added a comment -

          My situation is 2.263 to 2.269 that problem will be caused.
          If I reinstalled Jenkins it will be normal.
          I'm stilling try it . If I find how to reproduce I will report that. thank you.

          Show
          kimxinfo kim info added a comment - My situation is 2.263 to 2.269 that problem will be caused. If I reinstalled Jenkins it will be normal. I'm stilling try it . If I find how to reproduce I will report that. thank you.
          Hide
          kimxinfo kim info added a comment -

          Finally, I found the root cause is that the legacy TFS plugin cause the problem after upgrade to 2.264 above. I uninstalled it then solve the problem.
          ps:TFS Plugin was installed before five years ago. Now we used git server.

          Show
          kimxinfo kim info added a comment - Finally, I found the root cause is that the legacy TFS plugin cause the problem after upgrade to 2.264 above. I uninstalled it then solve the problem. ps:TFS Plugin was installed before five years ago. Now we used git server.

            People

            Assignee:
            kimxinfo kim info
            Reporter:
            kimxinfo kim info
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: