Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67396

Jobs build number context menu lost in new table design

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • core
    • 2.340

    Description

      I am not sure wheter this was intentional or just to clean the UI. in https://github.com/jenkinsci/jenkins/pull/5851

      Before

      After

      (no little arrow next to build number)

      Attachments

        Issue Links

          Activity

            timja Tim Jacomb added a comment - Cc janfaracik
            janfaracik Jan Faracik added a comment -

            Thanks for raising  Wasn't an intentional removal - I've got a fix for it here https://github.com/jenkinsci/jenkins/pull/6084 + some improved performance for those buttons

             

            Cheers

            janfaracik Jan Faracik added a comment - Thanks for raising  Wasn't an intentional removal - I've got a fix for it here https://github.com/jenkinsci/jenkins/pull/6084  + some improved performance for those buttons   Cheers
            janfaracik Jan Faracik added a comment -

            The fix for this has just been merged. Thanks for raising!

            janfaracik Jan Faracik added a comment - The fix for this has just been merged. Thanks for raising!
            janfaracik Jan Faracik added a comment - Fixed as part of  https://github.com/jenkinsci/jenkins/pull/6084

            janfaracik it seems that is causing JENKINS-68103 as well as others.

            alecharp Adrien Lecharpentier added a comment - janfaracik it seems that is causing JENKINS-68103 as well as others.
            basil Basil Crow added a comment -

            Hello janfaracik, there are currently 4 open regressions caused by this change:

            • JENKINS-68097 Credential domain dropdown floats into text (regression in 2.340)
            • JENKINS-68103 Clicking build progress bar no longer jumps to console output (regression in 2.340)
            • JENKINS-68129 Dropdown chevrons no longer separate lists (regression in 2.340)
            • JENKINS-68160 Context menu change causes weird behavior in build history (regression in 2.340)

            I fear that these issues will cause disruption to users if delivered in an LTS release. You are in a strong position to be able to resolve these issues efficiently; would you be able to take a look at them?

            basil Basil Crow added a comment - Hello janfaracik , there are currently 4 open regressions caused by this change: JENKINS-68097 Credential domain dropdown floats into text (regression in 2.340) JENKINS-68103 Clicking build progress bar no longer jumps to console output (regression in 2.340) JENKINS-68129 Dropdown chevrons no longer separate lists (regression in 2.340) JENKINS-68160 Context menu change causes weird behavior in build history (regression in 2.340) I fear that these issues will cause disruption to users if delivered in an LTS release. You are in a strong position to be able to resolve these issues efficiently; would you be able to take a look at them?

            People

              janfaracik Jan Faracik
              didiez Diego Díez
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: