Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-69454

No possible to run my jobs after upgrade WAR Stable 2.249.2 to 2.346.2

    XMLWordPrintable

Details

    Description

      Hello everyone,
      We are migrate our Jenkins to 2.249 to 2.346. We are upgrade all plugins and also Java version to JDK11.0.2 version
      All Jenkins Slaves are UP, no connection problems with jenkins master.
      A very good migration in this world (peace of cake)

      Now, all my jobs can't run (see attachment pics). Jobs still lock at theses steps and to stop the jobs I had to make a Hard Kill : 
      [Pipeline] Start of Pipeline
      [Pipeline] node  

      Even the simple HELLO WORLD pipeline not running. 

      First time I see this issue.
      Jenkins Community  please help

      Regard, Salution, Mit freundlichen Grüßen 

      LMO

      Attachments

        1. plugin_JenkinsV2.txt
          3 kB
        2. plugin_Jenkins.txt
          3 kB
        3. Capture4.PNG
          Capture4.PNG
          28 kB
        4. Capture3.PNG
          Capture3.PNG
          19 kB
        5. Capture2.PNG
          Capture2.PNG
          55 kB
        6. Capture1.PNG
          Capture1.PNG
          9 kB

        Activity

          lio_moun Lio Moun added a comment -

          Hi Martin,
          Thanks for quick reply.
          I just forgetten these plugins, my fault sorry !
          Now, plugins are upgrade.

          I have jdk-tool:1.5 and ldap:2.11

           

          lio_moun Lio Moun added a comment - Hi Martin, Thanks for quick reply. I just forgetten these plugins, my fault sorry ! Now, plugins are upgrade. I have  jdk-tool:1.5 and ldap:2.11  
          lio_moun Lio Moun added a comment -

          Ok Mark I will follow your answer.
          For your information I put the new plugin list. (plugin_JenkinsV2.txt)

          lio_moun Lio Moun added a comment - Ok Mark I will follow your answer. For your information I put the new plugin list. (plugin_JenkinsV2.txt )
          basil Basil Crow added a comment -

          Is this issue resolved after upgrading all plugins to the latest compatible versions?

          basil Basil Crow added a comment - Is this issue resolved after upgrading all plugins to the latest compatible versions?
          markewaite Mark Waite added a comment -

          The plugin list plugin_JenkinsV2.txt that lio_moun provided does not upgrade all plugins. There are 50 plugins that can be upgraded and there are security warnings for 5 plugins.

          Plugins that need to be upgraded include:

          • Active Directory
          • Ant
          • Apache HttpComponents Client 4.x API
          • Bootstrap 4 API
          • Bootstrap 5 API
          • Checks API
          • Command Agent Launcher
          • Credentials
          • Durable Task
          • External Monitor Job Type
          • Folders
          • Font Awesome API
          • GIT server
          • Git
          • JSch dependency
          • JUnit
          • Jakarta Activation API
          • Jakarta Mail API
          • JavaBeans Activation Framework (JAF) API
          • JavaMail API
          • Javadoc
          • Jersey 2 API
          • LDAP
          • Lockable Resources
          • Mailer
          • MapDB API
          • Matrix Authorization Strategy
          • Nexus Platform
          • OWASP Markup Formatter
          • Oracle Java SE Development Kit Installer
          • PAM Authentication
          • Pipeline: Basic Steps
          • Pipeline: Declarative
          • Pipeline: Declarative Agent API
          • Pipeline: Declarative Extension Points API
          • Pipeline: Groovy
          • Pipeline: Groovy Libraries
          • Pipeline: Job
          • Pipeline: Model API
          • Pipeline: Nodes and Processes
          • Pipeline: Stage Step
          • Pipeline: Stage Tags Metadata
          • Plain Credentials
          • Popper.js 2 API
          • Popper.js API
          • Role-based Authorization Strategy
          • SSH Build Agents
          • SSH Credentials
          • SnakeYAML API
          • Subversion
          • Variant
          • jQuery
          markewaite Mark Waite added a comment - The plugin list plugin_JenkinsV2.txt that lio_moun provided does not upgrade all plugins. There are 50 plugins that can be upgraded and there are security warnings for 5 plugins. Plugins that need to be upgraded include: Active Directory Ant Apache HttpComponents Client 4.x API Bootstrap 4 API Bootstrap 5 API Checks API Command Agent Launcher Credentials Durable Task External Monitor Job Type Folders Font Awesome API GIT server Git JSch dependency JUnit Jakarta Activation API Jakarta Mail API JavaBeans Activation Framework (JAF) API JavaMail API Javadoc Jersey 2 API LDAP Lockable Resources Mailer MapDB API Matrix Authorization Strategy Nexus Platform OWASP Markup Formatter Oracle Java SE Development Kit Installer PAM Authentication Pipeline: Basic Steps Pipeline: Declarative Pipeline: Declarative Agent API Pipeline: Declarative Extension Points API Pipeline: Groovy Pipeline: Groovy Libraries Pipeline: Job Pipeline: Model API Pipeline: Nodes and Processes Pipeline: Stage Step Pipeline: Stage Tags Metadata Plain Credentials Popper.js 2 API Popper.js API Role-based Authorization Strategy SSH Build Agents SSH Credentials SnakeYAML API Subversion Variant jQuery
          markewaite Mark Waite added a comment -

          Closing after one week with no response. Assume the submitter followed the instructions and resolved the issue in their installation.

          markewaite Mark Waite added a comment - Closing after one week with no response. Assume the submitter followed the instructions and resolved the issue in their installation.

          People

            Unassigned Unassigned
            lio_moun Lio Moun
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: