Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67823

GitHub organization folders not rendered correctly (regression in Jenkins 2.335)

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • core
    • 2.336 (Feb 22, 2022)

    Description

      The GitHub organization folders on my Jenkins instance do not render correctly with Jenkins 2.335. I assume an icon is missing somewhere.

      Similar issues seen elsewhere on the same instance:

      Similar issue is also visible in GitLab and Gitea organization folders.

      Removing the leading slash fixes it

       

       

      Attachments

        1. BrokenFoldersGiteaAndGitLab.png
          22 kB
          Han Geerligs
        2. image-2022-03-31-08-23-39-086.png
          9 kB
          Han Geerligs
        3. image-2022-03-31-08-24-36-959.png
          7 kB
          Han Geerligs
        4. screencapture-rhel-8-a-markwaite-net-8080-2022-02-16-15_01_42-edit.png
          148 kB
          Mark Waite
        5. Screenshot 2022-02-16 151144.png
          34 kB
          Mark Waite
        6. Screenshot 2022-02-17 083544.png
          35 kB
          Mark Waite
        7. Screenshot 2022-04-08 at 10.13.12.png
          199 kB
          Ben Middleton
        8. SlashRemoved.png
          22 kB
          Han Geerligs

        Issue Links

          Activity

            basil Basil Crow added a comment -

            Between JENKINS-67823, JENKINS-67849, JENKINS-67869, and JENKINS-67877 I am having a hard time understanding what issues remain at the time of current writing. If you are still experiencing an issue and are running the latest weekly and latest plugins, please leave a comment in this ticket so that we can assess what remains to be done for this work unit.

            basil Basil Crow added a comment - Between JENKINS-67823 , JENKINS-67849 , JENKINS-67869 , and JENKINS-67877 I am having a hard time understanding what issues remain at the time of current writing. If you are still experiencing an issue and are running the latest weekly and latest plugins, please leave a comment in this ticket so that we can assess what remains to be done for this work unit.
            phbaer Philipp Baer added a comment - - edited

            We're experiencing the issue still with Jenkins 2.342 and Bitbucket/Team Organization Folders with a path prefix. The icons are referenced like this:

            <img src="/jenkinshttps://some.domain.com/jenkins/custom-avatar-cache/69549bc20c74b266c34560cc7f5e182e.png?size=32x32" alt="Bitbucket Team/Project" tooltip="Bitbucket Team/Project" class="icon-lg" title="Bitbucket Team/Project">

             This situation is currently handled by the webserver with a redirect, hence no screen shot.

            phbaer Philipp Baer added a comment - - edited We're experiencing the issue still with Jenkins 2.342 and Bitbucket/Team Organization Folders with a path prefix . The icons are referenced like this: <img src="/jenkinshttps://some.domain.com/jenkins/custom-avatar-cache/69549bc20c74b266c34560cc7f5e182e.png?size=32x32" alt="Bitbucket Team/Project" tooltip="Bitbucket Team/Project" class="icon-lg" title="Bitbucket Team/Project">  This situation is currently handled by the webserver with a redirect, hence no screen shot.
            ben_gineer Ben Middleton added a comment -

            Similar here on latest build. We see this for both GitHub and Bitbucket organisations:

             

            And the source looks like this:

            <img src="/jenkinshttps://avatars.githubusercontent.com/u/7047555?v=4&amp;s=32" alt="GitHub Organization" tooltip="GitHub Organization" class="icon-lg" title="GitHub Organization"> 

            As you can see, the prefix is unnecessarily added to the beginning.

             

            ben_gineer Ben Middleton added a comment - Similar here on latest build. We see this for both GitHub and Bitbucket organisations:   And the source looks like this: <img src= "/jenkinshttps: //avatars.githubusercontent.com/u/7047555?v=4&amp;s=32" alt= "GitHub Organization" tooltip= "GitHub Organization" class= "icon-lg" title= "GitHub Organization" > As you can see, the prefix is unnecessarily added to the beginning.  
            basil Basil Crow added a comment -

            OK, so it seems the only remaining issues are not specific to plugin but are specific to prefix, i.e. JENKINS-67849. So it seems I picked the wrong bug to close. My apologies. Let me reopen JENKINS-67849 and close this one. Let's continue the discussion over at JENKINS-67849.

            basil Basil Crow added a comment - OK, so it seems the only remaining issues are not specific to plugin but are specific to prefix, i.e. JENKINS-67849 . So it seems I picked the wrong bug to close. My apologies. Let me reopen JENKINS-67849 and close this one. Let's continue the discussion over at JENKINS-67849 .
            basil Basil Crow added a comment -

            This ticket has gone beyond the point where it is possible to discern what problems have been solved and what problems remain, so I am closing it.

            If you are having a problem and are running with a prefix, see JENKINS-67849.

            If you are having a problem and are not running with a prefix, file a new ticket with labels "ux" and "regression", the specific plugin you are using, and steps to reproduce the problem from scratch.

            basil Basil Crow added a comment - This ticket has gone beyond the point where it is possible to discern what problems have been solved and what problems remain, so I am closing it. If you are having a problem and are running with a prefix, see JENKINS-67849 . If you are having a problem and are not running with a prefix, file a new ticket with labels "ux" and "regression", the specific plugin you are using, and steps to reproduce the problem from scratch .

            People

              notmyfault Alexander Brandes
              markewaite Mark Waite
              Votes:
              6 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: