Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67823

GitHub organization folders not rendered correctly (regression in Jenkins 2.335)

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • core
    • 2.336 (Feb 22, 2022)

    Description

      The GitHub organization folders on my Jenkins instance do not render correctly with Jenkins 2.335. I assume an icon is missing somewhere.

      Similar issues seen elsewhere on the same instance:

      Similar issue is also visible in GitLab and Gitea organization folders.

      Removing the leading slash fixes it

       

       

      Attachments

        Issue Links

          Activity

            Could you take a look at "Inspect Element" in the browser? That could lead us into the right direction of the icon missing.

            notmyfault Alexander Brandes added a comment - Could you take a look at "Inspect Element" in the browser? That could lead us into the right direction of the icon missing.
            han_geerligs Han Geerligs added a comment - - edited

            Hello,

             

            I observe the same behaviour for Gitea and GitLab organisation folders since updating to 2.335. See also attached image 

            --Han

            han_geerligs Han Geerligs added a comment - - edited Hello,   I observe the same behaviour for Gitea and GitLab organisation folders since updating to 2.335. See also attached image  --Han
            markewaite Mark Waite added a comment -

            Thanks han_geerligs

            notmyfault here is an image from "Inspect" on that location

            markewaite Mark Waite added a comment - Thanks han_geerligs notmyfault here is an image from "Inspect" on that location
            notmyfault Alexander Brandes added a comment - - edited

            Does removing the leading slash make it work again?

            The URL itself looks fine.

            Edit: Hm, the class looks malformed nevertheless, because it solely defines the size, unless I'm mistaken.  Yes I was 

            notmyfault Alexander Brandes added a comment - - edited Does removing the leading slash make it work again? The URL itself looks fine. Edit: Hm, the class looks malformed nevertheless, because it solely defines the size, unless I'm mistaken.   Yes I was 
            markewaite Mark Waite added a comment - - edited

            Yes, removing the leading '/' works.

            markewaite Mark Waite added a comment - - edited Yes, removing the leading '/' works.
            han_geerligs Han Geerligs added a comment -

            I can confirm that removing the / makes the icon visible again! See attachment.

             

            --Han

            han_geerligs Han Geerligs added a comment - I can confirm that removing the / makes the icon visible again! See attachment.   --Han

            It seems to prepend the context path and then adds the configured jenkins url, before adding the actual sub path.

            cschoell Christof Schoell added a comment - It seems to prepend the context path and then adds the configured jenkins url, before adding the actual sub path.
            phbaer Philipp Baer added a comment - - edited

            This is still an issue in 2.336 for Organization Folders configured for Bitbucket Team/Project.

            Had to roll back to 2.334.

            phbaer Philipp Baer added a comment - - edited This is still an issue in 2.336 for Organization Folders configured for Bitbucket Team/Project. Had to roll back to 2.334.
            notmyfault Alexander Brandes added a comment - - edited

            Let's move this specific issue to https://issues.jenkins.io/browse/JENKINS-67877, because JENKINS-67823 is a different one.

            notmyfault Alexander Brandes added a comment - - edited Let's move this specific issue to https://issues.jenkins.io/browse/JENKINS-67877 , because JENKINS-67823 is a different one.
            han_geerligs Han Geerligs added a comment - - edited

            Hello,

             

            I observe that this issue occurs again for GitLab Branch Source with the latest release (Jenkins 2.342).

            URL for missing icon is http://han_mob:8080/gitlab-logo

            When going to the folder page the GitLab logo is displayed correctly:

            URL for correct folder icon is http://han_mob:8080/static/829452d6/plugin/gitlab-branch-source/images/48x48/gitlab-logo.png 

            --Han

            han_geerligs Han Geerligs added a comment - - edited Hello,   I observe that this issue occurs again for GitLab Branch Source with the latest release ( Jenkins 2.342 ). URL for missing icon is http://han_mob:8080/gitlab-logo When going to the folder page the GitLab logo is displayed correctly: URL for correct folder icon is http://han_mob:8080/static/829452d6/plugin/gitlab-branch-source/images/48x48/gitlab-logo.png   --Han

            It also works well without host: /static/829452d6/plugin/gitlab-branch-source/images/48x48/gitlab-logo.png

            gulyas_istvan_netlock István Gulyás added a comment - It also works well without host: /static/829452d6/plugin/gitlab-branch-source/images/48x48/gitlab-logo.png
            notmyfault Alexander Brandes added a comment - cc janfaracik
            basil Basil Crow added a comment -

            Between JENKINS-67823, JENKINS-67849, JENKINS-67869, and JENKINS-67877 I am having a hard time understanding what issues remain at the time of current writing. If you are still experiencing an issue and are running the latest weekly and latest plugins, please leave a comment in this ticket so that we can assess what remains to be done for this work unit.

            basil Basil Crow added a comment - Between JENKINS-67823 , JENKINS-67849 , JENKINS-67869 , and JENKINS-67877 I am having a hard time understanding what issues remain at the time of current writing. If you are still experiencing an issue and are running the latest weekly and latest plugins, please leave a comment in this ticket so that we can assess what remains to be done for this work unit.
            phbaer Philipp Baer added a comment - - edited

            We're experiencing the issue still with Jenkins 2.342 and Bitbucket/Team Organization Folders with a path prefix. The icons are referenced like this:

            <img src="/jenkinshttps://some.domain.com/jenkins/custom-avatar-cache/69549bc20c74b266c34560cc7f5e182e.png?size=32x32" alt="Bitbucket Team/Project" tooltip="Bitbucket Team/Project" class="icon-lg" title="Bitbucket Team/Project">

             This situation is currently handled by the webserver with a redirect, hence no screen shot.

            phbaer Philipp Baer added a comment - - edited We're experiencing the issue still with Jenkins 2.342 and Bitbucket/Team Organization Folders with a path prefix . The icons are referenced like this: <img src="/jenkinshttps://some.domain.com/jenkins/custom-avatar-cache/69549bc20c74b266c34560cc7f5e182e.png?size=32x32" alt="Bitbucket Team/Project" tooltip="Bitbucket Team/Project" class="icon-lg" title="Bitbucket Team/Project">  This situation is currently handled by the webserver with a redirect, hence no screen shot.
            ben_gineer Ben Middleton added a comment -

            Similar here on latest build. We see this for both GitHub and Bitbucket organisations:

             

            And the source looks like this:

            <img src="/jenkinshttps://avatars.githubusercontent.com/u/7047555?v=4&amp;s=32" alt="GitHub Organization" tooltip="GitHub Organization" class="icon-lg" title="GitHub Organization"> 

            As you can see, the prefix is unnecessarily added to the beginning.

             

            ben_gineer Ben Middleton added a comment - Similar here on latest build. We see this for both GitHub and Bitbucket organisations:   And the source looks like this: <img src= "/jenkinshttps: //avatars.githubusercontent.com/u/7047555?v=4&amp;s=32" alt= "GitHub Organization" tooltip= "GitHub Organization" class= "icon-lg" title= "GitHub Organization" > As you can see, the prefix is unnecessarily added to the beginning.  
            basil Basil Crow added a comment -

            OK, so it seems the only remaining issues are not specific to plugin but are specific to prefix, i.e. JENKINS-67849. So it seems I picked the wrong bug to close. My apologies. Let me reopen JENKINS-67849 and close this one. Let's continue the discussion over at JENKINS-67849.

            basil Basil Crow added a comment - OK, so it seems the only remaining issues are not specific to plugin but are specific to prefix, i.e. JENKINS-67849 . So it seems I picked the wrong bug to close. My apologies. Let me reopen JENKINS-67849 and close this one. Let's continue the discussion over at JENKINS-67849 .
            basil Basil Crow added a comment -

            This ticket has gone beyond the point where it is possible to discern what problems have been solved and what problems remain, so I am closing it.

            If you are having a problem and are running with a prefix, see JENKINS-67849.

            If you are having a problem and are not running with a prefix, file a new ticket with labels "ux" and "regression", the specific plugin you are using, and steps to reproduce the problem from scratch.

            basil Basil Crow added a comment - This ticket has gone beyond the point where it is possible to discern what problems have been solved and what problems remain, so I am closing it. If you are having a problem and are running with a prefix, see JENKINS-67849 . If you are having a problem and are not running with a prefix, file a new ticket with labels "ux" and "regression", the specific plugin you are using, and steps to reproduce the problem from scratch .

            People

              notmyfault Alexander Brandes
              markewaite Mark Waite
              Votes:
              6 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: