Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67877

Bitbucket organization folder not rendered correctly in 2.335 and 2.336

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • None
    • Jenkins 2.335 and 2.336
      cloudbees-bitbucket-branch-source:756.v081ee2205040
    • 757.vddedc5f2589a_

    Description

      The Bitbucket team / organization folders do not render correctly with Jenkins 2.335 and Jenkins 2.336. It looks like this:

      The inspect of the affected elements shows this:

      Attachments

        Issue Links

          Activity

            basil Basil Crow added a comment -

            Between JENKINS-67823, JENKINS-67849, JENKINS-67869, and JENKINS-67877 I am having a hard time understanding what issues remain at the time of current writing. If you are still experiencing an issue and are running the latest weekly and latest plugins, please leave a comment in JENKINS-67823 (not this ticket!) so that we can assess what remains to be done for this work unit.

            basil Basil Crow added a comment - Between JENKINS-67823 , JENKINS-67849 , JENKINS-67869 , and JENKINS-67877 I am having a hard time understanding what issues remain at the time of current writing. If you are still experiencing an issue and are running the latest weekly and latest plugins, please leave a comment in JENKINS-67823 (not this ticket!) so that we can assess what remains to be done for this work unit.
            notmyfault Alexander Brandes added a comment - - edited

            Yeah, that would be part of the issue I linked before.
            This issue targets the typo in the icon registry which was "icon-bitbucket-scmnavigator icon-<size>" instead of "icon-bitbucket-scm-navigator icon-<size>" before, that caused the default icon to not show.

            notmyfault Alexander Brandes added a comment - - edited Yeah, that would be part of the issue I linked before. This issue targets the typo in the icon registry which was "icon-bitbucket-scmnavigator icon-<size>" instead of "icon-bitbucket-scm-navigator icon-<size>" before, that caused the default icon to not show.

            Sure:

            <img src="/jenkinshttps://ourjenkins.de/jenkins/custom-avatar-cache/1ec36e9f1a1fb54db76fdc2a5a60b6c5.png?size=48x48" alt="Bitbucket Team/Project" width="48" tooltip="Bitbucket Team/Project" height="48" title="Bitbucket Team/Project">
            

            It seems to incorrectly add the full url after the path prefix (which is probably added via tomcat/servlet context path?)

            cschoell Christof Schoell added a comment - Sure: <img src= "/jenkinshttps: //ourjenkins.de/jenkins/custom-avatar-cache/1ec36e9f1a1fb54db76fdc2a5a60b6c5.png?size=48x48" alt= "Bitbucket Team/Project" width= "48" tooltip= "Bitbucket Team/Project" height= "48" title= "Bitbucket Team/Project" > It seems to incorrectly add the full url after the path prefix (which is probably added via tomcat/servlet context path?)

            Do you mind inspecting the missing icon element and provide the findings? That could help to provide additional information about the issue.

            notmyfault Alexander Brandes added a comment - Do you mind inspecting the missing icon element and provide the findings? That could help to provide additional information about the issue.

            I have the same issue when running jenkins in a tomcat (deployed as war) - no --prefix set but exactly this behaviour (2.338)

            cschoell Christof Schoell added a comment - I have the same issue when running jenkins in a tomcat (deployed as war) - no --prefix set but exactly this behaviour (2.338)

            People

              notmyfault Alexander Brandes
              markewaite Mark Waite
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: